summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-08-05 09:04:33 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2021-05-09 14:27:14 +0200
commitbaead93633bff69556e5d198ed9ed29bc4fe84aa (patch)
tree5d8e13b4b7fa0ae36c74032db54507b294cec154
parenta602c0e3a308c31abbd9d666a07ce483ea19f223 (diff)
pcr: add guile-git for developping with guile 3GNUtoo/guile-3-wip
guile-git has Guile version 3. Upstream Guix uses guile 3, while the Parabola package uses version 2.2: $ pacman -Q -i guix [...] Depends On : guile>=2.2.4 [...] This can create issues when manually compiling Guix git against Parabola guile package and using ./pre-inst-env for testing patches before sending them upstream: as the guile version is different, loading the compiled scm takes a huge amount of time and we also gets warnings like that for many files: ;;; WARNING: loading compiled file [...]/gnu/packages/messaging.go failed: ;;; In procedure load-thunk-from-memory: ELF file does not have native word size AUR also has many packages that depend on guile which is also provided by guile-git, however people using AUR are typically compiling the PKGBUILD themselves, and as I understand using guile-git with packaged software would require to recompile them for guile 3. However in practice that breaks guix's configure as it detects that /usr/bin/guile is not the same than the lastest guile. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--pcr/guile-git/PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/pcr/guile-git/PKGBUILD b/pcr/guile-git/PKGBUILD
new file mode 100644
index 000000000..17f380f7a
--- /dev/null
+++ b/pcr/guile-git/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer (AUR): Stefan Husmann <stefan-husmann@t-online.de>
+
+# parabola changes and rationale:
+# no changes.
+
+pkgname=guile-git
+epoch=1
+_majorver=3.0
+pkgver=3.0.4.r24.gd238566d0
+pkgrel=1
+pkgdesc="A portable, embeddable Scheme implementation (Git snapshot)"
+arch=('i686' 'x86_64' 'aarch64')
+license=('GPL')
+makedepends=('git')
+optdepends=('texinfo: for using texinfo scheme sources')
+depends=('gc' 'libtool' 'libffi' 'libunistring' 'gmp' 'readline')
+provides=('guile')
+conflicts=('guile4emacs')
+options=('!strip' '!makeflags' 'libtool')
+source=("git+https://git.savannah.gnu.org/git/${pkgname%-git}.git")
+url="http://www.gnu.org/software/guile/"
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags | sed 's+-+.r+' | sed 's+^v++' | tr - .
+}
+
+build() {
+ cd ${pkgname%-git}
+ ./autogen.sh
+ ./configure --prefix=/usr --program-suffix=${_majorver}
+ make LDFLAGS+=" -lpthread"
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir/" install
+ cd "$pkgdir"/usr/share/info
+ for i in guile*
+ do
+ mv $i guile-${_majorver}${i#guile}
+ done
+ mv r5rs.info r5rs-${_majorver}.info
+ mv "$pkgdir"/usr/share/aclocal/guile.m4 "$pkgdir"/usr/share/aclocal/guile-${_majorver}.m4
+ rm "$pkgdir"/usr/lib/libguile-3.0.so.*-gdb.scm
+}