summaryrefslogtreecommitdiff
path: root/kernels/linux-libre-pae/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-09-30 08:05:36 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-09-30 08:06:57 -0300
commit26ac02527f3475a05770da09872259d9ea6eca21 (patch)
tree64535c362ab8bfe26b85b3881ac60ce8f28d8e89 /kernels/linux-libre-pae/PKGBUILD
parent44006ac3d71fb4c1ee2bca9560d578991bc4b501 (diff)
linux-libre-{pae,xen}-4.2.1_gnu-1: updating version
Diffstat (limited to 'kernels/linux-libre-pae/PKGBUILD')
-rw-r--r--kernels/linux-libre-pae/PKGBUILD39
1 files changed, 29 insertions, 10 deletions
diff --git a/kernels/linux-libre-pae/PKGBUILD b/kernels/linux-libre-pae/PKGBUILD
index 9b9d3cdd7..098139b2c 100644
--- a/kernels/linux-libre-pae/PKGBUILD
+++ b/kernels/linux-libre-pae/PKGBUILD
@@ -8,11 +8,11 @@
# Based on linux-pae package
pkgbase=linux-libre-pae
-_pkgbasever=4.1-gnu
-_pkgver=4.1.6-gnu
+_pkgbasever=4.2-gnu
+_pkgver=4.2.1-gnu
_replacesarchkernel=('linux%') # '%' gets replaced with _kernelname
-_replacesoldkernels=('kernel26%' 'kernel26-libre%') # '%' gets replaced with _kernelname
+_replacesoldkernels=() # '%' gets replaced with _kernelname
_replacesoldmodules=() # '%' gets replaced with _kernelname
_srcname=linux-${_pkgbasever%-*}
@@ -39,10 +39,13 @@ source=("http://linux-libre.fsfla.org/pub/linux-libre/releases/${_pkgbasever}/li
# standard config files for mkinitcpio ramdisk
'linux.preset'
'change-default-console-loglevel.patch'
+ '0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch'
+ '0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch'
+ '0001-fix-bridge-regression.patch'
'0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch')
-sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
+sha256sums=('3a8fc9da5a38f15cc4ed0c5132d05b8245dfc1007c37e7e1994b2486535ecf49'
'SKIP'
- '335d3e07319ddf393c69e047c27bc5d28ee9e6126282619e3364db56a4331d34'
+ '2fb0b42c6cac0bd550ceb71072fef4f7ed72976e64542de8e7ad759a9e195237'
'SKIP'
'bfd4a7f61febe63c880534dcb7c31c5b932dde6acf991810b41a939a93535494'
'SKIP'
@@ -50,10 +53,13 @@ sha256sums=('48b2e5ea077d0a0bdcb205e67178e8eb5b2867db3b2364b701dbc801d9755324'
'SKIP'
'6de8a8319271809ffdb072b68d53d155eef12438e6d04ff06a5a4db82c34fa8a'
'SKIP'
- '1a9eaa79032093b0849767ff015b06e835bda3076a2dcae7a94e95d82aeaa44b'
+ 'fb826ec4240cf60040cf6b7c39bc17a9430ded25598e1a39c5f3c8c4f99ac090'
'f0d90e756f14533ee67afda280500511a62465b4f76adcc5effa95a40045179c'
'1256b241cd477b265a3c2d64bdc19ffe3c9bbcee82ea3994c590c2c76e767d99'
- '38cf6bdf70dc070ff0b785937d99347bb91f8531ea2bcca50283c8923a184c6d')
+ '0b1e41ba59ae45f5929963aa22fdc53bc8ffb4534e976cec046269d1a462197b'
+ '6ed9e31ae5614c289c4884620e45698e764c03670ebc45bab9319d741238cbd3'
+ '0a8fe4434e930d393c7983e335842f6cb77ee263af5592a0ca7e14bae7296183'
+ '61370b766e0c60b407c29d2c44b3f55fc352e9049c448bc8fcddb0efc53e42fc')
validpgpkeys=(
'474402C8C582DAFBE389C427BCB7CF877E7D47A7' # Alexandre Oliva
'684D54A189305A9CC95446D36B888913DDB59515' # Márcio Silva
@@ -79,6 +85,19 @@ prepare() {
# add latest fixes from stable queue, if needed
# http://git.kernel.org/?p=linux/kernel/git/stable/stable-queue.git
+ # fix hard lockup in e1000e_cyclecounter_read() after 4 hours of uptime
+ # https://lkml.org/lkml/2015/8/18/292
+ patch -p1 -i "${srcdir}/0001-e1000e-Fix-tight-loop-implementation-of-systime-read.patch"
+
+ # add not-yet-mainlined patch to fix network unavailability when iptables
+ # rules are applied during startup - happened with Shorewall; journal had
+ # many instances of this error: nf_conntrack: table full, dropping packet
+ patch -p1 -i "${srcdir}/0001-netfilter-conntrack-use-nf_ct_tmpl_free-in-CT-synpro.patch"
+
+ # add not-yes-mainlined patch to fix bridge code
+ # https://bugzilla.kernel.org/show_bug.cgi?id=104161
+ patch -Np1 -i "${srcdir}/0001-fix-bridge-regression.patch"
+
# set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
# remove this when a Kconfig knob is made available by upstream
# (relevant patch sent upstream: https://lkml.org/lkml/2011/7/26/227)
@@ -86,7 +105,7 @@ prepare() {
# Make the radeon driver load without the firmwares
# http://www.fsfla.org/pipermail/linux-libre/2015-August/003098.html
- patch -Np1 -i ../0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch
+ patch -p1 -i "${srcdir}/0001-drm-radeon-Make-the-driver-load-without-the-firmwares.patch"
cat "${srcdir}/config" > ./.config # simpler
@@ -176,7 +195,7 @@ _package() {
mv "${pkgdir}/lib" "${pkgdir}/usr/"
# add vmlinux
- install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
+ install -D -m644 vmlinux "${pkgdir}/usr/lib/modules/${_kernver}/build/vmlinux"
}
_package-headers() {
@@ -296,7 +315,7 @@ _package-headers() {
done
# remove unneeded architectures
- find "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch -mindepth 1 -maxdepth 1 -type d -not -name "x86" -exec rm -rf {} +
+ find "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch -mindepth 1 -maxdepth 1 -type d -not -name "$KARCH" -exec rm -rf {} +
}
_package-docs() {