summaryrefslogtreecommitdiff
path: root/libre-testing/uboot4grub-am335x_bone/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-14 08:28:04 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-10-14 08:30:23 -0300
commitb9de19ba52d54a7e608656254bb43c2441707853 (patch)
treeefeec15469e4e8e926cbf38fb63b4c71e9b7ae98 /libre-testing/uboot4grub-am335x_bone/PKGBUILD
parent776999f7876ddc85f4212202fc4ec3b4389dd784 (diff)
rename uboot-grub-beaglebone to uboot4grub-am335x_bone
Diffstat (limited to 'libre-testing/uboot4grub-am335x_bone/PKGBUILD')
-rw-r--r--libre-testing/uboot4grub-am335x_bone/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/libre-testing/uboot4grub-am335x_bone/PKGBUILD b/libre-testing/uboot4grub-am335x_bone/PKGBUILD
new file mode 100644
index 000000000..c32adac42
--- /dev/null
+++ b/libre-testing/uboot4grub-am335x_bone/PKGBUILD
@@ -0,0 +1,43 @@
+# U-Boot: BeagleBone and BeagleBone Black
+# Maintainer: André Silva <emulatorman@parabola.nu>
+
+buildarch=4
+
+pkgname=uboot4grub-am335x_bone
+pkgver=2015.04
+pkgrel=1
+pkgdesc="U-Boot with GRUB support for BeagleBone and BeagleBone Black"
+arch=('armv7h')
+url="http://git.denx.de/u-boot.git/"
+depends=('grub-am335x_bone')
+replaces=('uboot-beaglebone' 'uboot-grub-beaglebone')
+conflicts=('uboot-beaglebone' 'uboot4grub' 'uboot-grub-beaglebone')
+provides=('uboot-beaglebone' 'uboot4grub')
+makedepends=('bc')
+license=('GPL')
+install=${pkgname}.install
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
+ '0001-parabola-arm-modifications+grub-support.patch')
+md5sums=('570bdc2c47270c2a98ca60ff6c5c74cd'
+ 'd8c8e9fea003cd06ef04fe1cd841d686')
+
+prepare() {
+ cd u-boot-${pkgver}
+ patch -Np1 -i ../0001-parabola-arm-modifications+grub-support.patch
+}
+
+build() {
+ cd u-boot-${pkgver}
+
+ unset CFLAGS CXXFLAGS LDFLAGS
+
+ make distclean
+ make am335x_evm_config
+ make
+}
+
+package() {
+ cd u-boot-${pkgver}
+ mkdir -p "${pkgdir}"/boot
+ cp MLO u-boot.img "${pkgdir}"/boot
+}