summaryrefslogtreecommitdiff
path: root/libre/acpi_call-dkms/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2020-12-08 20:01:06 +0100
committerAndreas Grapentin <andreas@grapentin.org>2020-12-08 20:01:06 +0100
commitdf96ee4a70df70d029d6285be9c44113507b377a (patch)
tree2ec1299ff81daee267eed6f26eb81ae1f6a56369 /libre/acpi_call-dkms/PKGBUILD
parent770de002867b114223bb2ba91af7259b90be65d1 (diff)
libre/acpi-call{,-dkms,-lts}: reworked and rebuilt for new kernels
Diffstat (limited to 'libre/acpi_call-dkms/PKGBUILD')
-rw-r--r--libre/acpi_call-dkms/PKGBUILD62
1 files changed, 29 insertions, 33 deletions
diff --git a/libre/acpi_call-dkms/PKGBUILD b/libre/acpi_call-dkms/PKGBUILD
index 101fc0fc9..e0b3f960c 100644
--- a/libre/acpi_call-dkms/PKGBUILD
+++ b/libre/acpi_call-dkms/PKGBUILD
@@ -6,45 +6,41 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.8.3
+_basekernel=5.9.12
pkgname=acpi_call-dkms
-pkgver=1.1.0
-pkgrel=287
+pkgver=1.2.1
+pkgrel=2
pkgrel+=.parabola1.basekernel${_basekernel}
pkgdesc='A linux kernel module that enables calls to ACPI methods through /proc/acpi/call - module sources'
pkgdesc+=' (for linux-libre)'
-url='https://github.com/mkottman/acpi_call'
-arch=('x86_64')
-arch+=('i686')
-license=('GPL')
-depends=('dkms')
-makedepends=(linux-libre-headers=${_basekernel})
-provides=("acpi_call=$pkgver-${pkgrel%%.*}")
-conflicts=('acpi_call')
-source=("acpi_call-${pkgver}.tar.gz::https://github.com/mkottman/acpi_call/archive/v${pkgver}.tar.gz"
- '0001-linux-5.6.patch'
- 'dkms.conf')
-sha256sums=('d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0'
- '1f397f087fd96d5286907c90f518bbe68b0d19f83ab30bb124f76a19693a932c'
- '32e6ea6523b13132c6c7838bba7fbf3d040ba2d35a892c2c356245612720df8a')
-
-prepare() {
- cd acpi_call-$pkgver
-
- # Fix build with Linux >= 5.6
- # also: Linux-libre >= 3.17-gnu (acpi.h)
- # also: Linux-libre >= 4.12-gnu (uaccess.h)
- patch -Np1 < ../0001-linux-5.6.patch
+url=https://github.com/nix-community/acpi_call
+arch=(x86_64 i686)
+license=(GPL)
+depends=(dkms)
+makedepends=(
+ git
+ linux-libre-headers=${_basekernel}
+)
+provides=(acpi_call=${pkgver}-${pkgrel%%.*})
+conflicts=(acpi_call)
+_tag=3a28aabfa337d59df91cc04c85b250da7f7cadea
+source=(
+ git+https://github.com/nix-community/acpi_call.git#tag=${_tag}
+ dkms.conf
+)
+b2sums=('SKIP'
+ '504da1102e778fe54368e990408dbef02f5b2ce91f683d170f3d6a1a2f9349d00d61dcbddd0262a8dfc958ea0964135ba58d8dd88ac06bd10b5e13b90f11faef')
+
+pkgver() {
+ cd acpi_call
+
+ git describe --tags | sed 's/^v//'
}
package() {
- cd acpi_call-$pkgver
-
- install -Dt "$pkgdir/usr/src/acpi_call-$pkgver" -m0644 Makefile acpi_call.c ../dkms.conf
-
- echo acpi_call | install -Dm0644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/acpi_call.conf"
-
- mkdir -p "$pkgdir/usr/share/acpi_call"
- cp -t "$pkgdir/usr/share/acpi_call" -dr --no-preserve=ownership examples support
+ install -Dm 644 acpi_call/{Makefile,acpi_call.c} dkms.conf -t "${pkgdir}"/usr/src/acpi_call-${pkgver}
+ echo acpi_call | install -Dm 644 /dev/stdin "${pkgdir}"/usr/lib/modules-load.d/acpi_call.conf
+ install -dm 755 "${pkgdir}"/usr/share/acpi_call
+ cp -dr --no-preserve=ownership acpi_call/{examples,support} "${pkgdir}"/usr/share/acpi_call/
}