summaryrefslogtreecommitdiff
path: root/libre/blender/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-01-31 01:43:43 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2019-02-02 09:07:55 -0500
commit424bd40d884f503692d2bcab945375ecae07542e (patch)
tree44ce2ea92d49c8f1e583cc296cf1780ea77ab750 /libre/blender/PKGBUILD
parent2c38f92da499fb18e22123f76b3158c46e3247cc (diff)
[blender]: upgrade to git-2c0c1f494dcfadb3c01d23e2348e28bc8864e9f3
Diffstat (limited to 'libre/blender/PKGBUILD')
-rw-r--r--libre/blender/PKGBUILD56
1 files changed, 25 insertions, 31 deletions
diff --git a/libre/blender/PKGBUILD b/libre/blender/PKGBUILD
index 7ed227d79..b8aab3b4b 100644
--- a/libre/blender/PKGBUILD
+++ b/libre/blender/PKGBUILD
@@ -16,12 +16,12 @@
# unreasonable.
# _gittag=v2.79b
-_gitcommit=32432d91bbec558cbd88e54aece61b0d641c1761
+_gitcommit=2c0c1f494dcfadb3c01d23e2348e28bc8864e9f3
pkgname=blender
pkgver=2.79.b
-[[ -n $_gitcommit ]] && pkgver=${pkgver}.git3.${_gitcommit:0:8}
-pkgrel=8
+[[ -n $_gitcommit ]] && pkgver=${pkgver}.git4.${_gitcommit:0:8}
+pkgrel=3
pkgrel+=.parabola1
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
@@ -36,36 +36,30 @@ depends=('libpng' 'libtiff' 'openexr' 'python' 'desktop-file-utils' 'python-requ
'openimageio' 'libsndfile' 'jack' 'opencolorio' 'openshadinglanguage'
'jemalloc' 'libspnav' 'ptex' 'opensubdiv' 'openvdb' 'log4cplus' 'sdl2')
makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm')
-if [[ "$CARCH" == arm* ]]; then
- makedepends=('cmake' 'boost' 'mesa' 'git' 'llvm')
-fi
options=(!strip)
source=("git://git.blender.org/blender-addons.git"
"git://git.blender.org/blender-addons-contrib.git"
"git://git.blender.org/blender-translations.git"
"git://git.blender.org/blender-dev-tools.git"
"git://git.blender.org/scons.git"
- python37.patch
- ffmpeg4.0.patch
- tree_hpp.patch
- util_sseb.patch
- openvdb3-abi.patch)
+ stl_export_iter.patch
+ python3.7.patch
+ arm-no-sse2.patch)
+
if [[ -n $_gittag ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#tag=${_gittag}")
elif [[ -n $_gitcommit ]]; then
source+=("${pkgname}-${pkgver}::git://git.blender.org/blender.git#commit=${_gitcommit}")
fi
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '1d6d2064db0e8e4e3a52735406f5106a'
- 'da14d7cbdea1ab5499659a066658cdd2'
- 'feea89510de171946c41c6208461f453'
- '53da216adbc2a9d555a59c15b8f0ef08'
- '3f9613fcb7ea61214982272e9c20a294'
- 'SKIP')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '51f30acc407179f003d1dbec25fb47b0bf1fe8d2eb16e069a6ca83ab8b21f6032d636a42e0b140537ad1ad25ad38c52a87a2a33e51822729ab196fcef4682818'
+ 'f5564e8db242f6fa9cd951590f4c6de8f5b1a8bbd73aeb6e837a840dd2696e71f7b6bb1c94f9c2377b199159f87a95bead8ee113c01e8763f3843918395cc177'
+ '927680b39b3666f6599e4ebcb52b57476b42e9ed89b7e40060c38cd0c36130be86eabdf7c5b8be54f11f26dc222e423fa3e494ede8d6d83c38863241563f181a'
+ 'SKIP')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -81,18 +75,17 @@ prepare() {
# fix OS Name (pedantic, I know)
sed -i 's|BUILD_PLATFORM;|"GNU/Linux-libre";|' 'source/creator/buildinfo.c'
- patch -Np1 -i "$srcdir"/python37.patch
- patch -Np1 -i "$srcdir"/ffmpeg4.0.patch
- patch -Np1 -i "$srcdir"/tree_hpp.patch
- patch -Np1 -i "$srcdir"/util_sseb.patch
- patch -Np1 -i "$srcdir"/openvdb3-abi.patch
+ patch -Np1 -i "$srcdir"/stl_export_iter.patch
+ patch -Np1 -i "$srcdir"/python3.7.patch -d release/scripts/addons_contrib
+if [[ "$CARCH" == arm* ]]; then
+ patch -Np1 -i "$srcdir"/arm-no-sse2.patch
+fi
+
+ mkdir build
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- [[ -d build ]] && rm -rf build
- mkdir build && cd build
+ cd "$srcdir/$pkgname-$pkgver"/build
cmake -C../build_files/cmake/config/blender_release.cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -107,6 +100,7 @@ build() {
-DWITH_CYCLES_CUDA_BINARIES='OFF' \
-DWITH_CYCLES_DEVICE_CUDA='OFF' \
-DWITH_CYCLES_PTEX=OFF \
+ -DWITH_OPENVDB_3_ABI_COMPATIBLE=ON \
-DPYTHON_VERSION=3.7 \
-DPYTHON_LIBPATH=/usr/lib \
-DPYTHON_LIBRARY=python3.7m \