summaryrefslogtreecommitdiff
path: root/libre/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-12-17 16:52:22 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-12-17 16:52:22 -0500
commit0d1de9a2c77798a18f368b80334664f5952684bc (patch)
treeff9b7002be9d970cb491c3c71eda3c1e29faed23 /libre/filesystem/PKGBUILD
parent18cc9ec7fa83a01503e2038580e2cde7dd4a9dc7 (diff)
filesystem-2017.10-2.parabola1: updating version
Diffstat (limited to 'libre/filesystem/PKGBUILD')
-rw-r--r--libre/filesystem/PKGBUILD259
1 files changed, 112 insertions, 147 deletions
diff --git a/libre/filesystem/PKGBUILD b/libre/filesystem/PKGBUILD
index cdccddd40..344d32877 100644
--- a/libre/filesystem/PKGBUILD
+++ b/libre/filesystem/PKGBUILD
@@ -1,163 +1,128 @@
# $Id: PKGBUILD 291699 2017-03-26 22:06:04Z seblu $
# Maintainer (Arch): Sébastien Luttringer
# Contributor (Arch): Tom Gundersen <teg@jklm.no>
-# Maintainer: Nicolás Reynolds <fauno@kiwwwi.com.ar>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
pkgname=filesystem
-pkgver=2017.03
-pkgrel=2.parabola2
+pkgver=2017.10
+pkgrel=2.parabola1
pkgdesc='Base Parabola GNU/Linux-libre files'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
url='https://www.parabola.nu'
groups=('base' 'base-openrc')
-install='filesystem.install'
-makedepends=('asciidoc')
depends=('iana-etc')
replaces=(filesystem-parabola)
conflicts=(filesystem-parabola)
-backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
- 'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
- 'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
-source=('group' 'issue' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
- 'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
- 'shells' 'gshadow' 'profile' 'parabola.7.txt' 'locale.sh')
-md5sums=('76c80215d8dd395d3be4b8a711d585b6'
- '6be47d893fd49b2e4a8c0e811b350861'
- '7b21f0f97f048988908bf93778bba65f'
- '4c4540eeb748bf1f71d631b8c1dcf0b3'
- 'f28150d4c0b22a017be51b9f7f9977ed'
- '6e488ffecc8ba142c0cf7e2d7aeb832e'
- 'cb1a751b05541d8eebaace316de0e809'
- 'c0c27476ee248355bf308c8502a8c860'
- '693c97f2c9a519bb97a17008e92c2b74'
- 'dfae4294e5e20d9fcffefc35d18d7334'
- '7bc65f234dfb6abf24e7c3b03e86f4ff'
- 'd41d8cd98f00b204e9800998ecf8427e'
- 'b1035460b265c01a040ac99d5ad4631b'
- '6f48288b6fcaf0065fcb7b0e525413e0'
- '22518e922891f9359f971f4f5b4e793c'
- 'c08581d4f982be8806d3afa912a65203'
- 'cfa3345c485c59e681ab39a44dc7ece1'
- 'd5732ffdb3488e1383d4ea199343e767'
- '71ed98c52e11ada1f936ac8cb14eecd9')
-
-lint() {
- # ensure that passwd is sync'd to shadow and group is sync'd to gshadow.
- local r=0
-
- local passwd shadow group gshadow
-
- for f in passwd shadow group gshadow; do
- mapfile -t "$f" < <(cut -d: -f1 "$f" | sort)
- done
-
- # we can cheat and do simple string comparison only because we can make some
- # assumptions about the data in these files
- if [[ ${passwd[*]} != "${shadow[*]}" ]]; then
- error 'passwd is not in sync with shadow!'
- r=1
- fi
-
- if [[ ${group[*]} != "${gshadow[*]}" ]]; then
- error 'group is not in sync with gshadow!'
- r=1
- fi
-
- return $r
-}
-
-build() {
- cd "$srcdir"
-
- lint
-
- a2x -d manpage -f manpage parabola.7.txt
-}
+backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
+ 'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
+ 'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
+ 'etc/shadow' 'etc/shells')
+source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
+ 'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
+ 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells'
+ 'sysusers' 'tmpfiles')
+sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
+ 'ed0cb4f1db4021f8c3b5ce78fdf91d2c0624708f58f36c9cf867f4d93c3bc6da'
+ 'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
+ '244f0718ee2a9d6862ae59d6c18c1dd1568651eada91a704574fa527fbac2b3a'
+ '90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
+ '4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
+ 'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
+ '3ad448c78cab733759ae3365620504b1444e854effd066f1c7174652f046ebe1'
+ 'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
+ '331805ff85b80ae2444be58740f1cf41be56fb6e254e930677f1e36e8f95bee1'
+ 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
+ 'c2d603373e1c6db0acdd79ec36cbe19920b5213d6b76f9d56b2a5010bad8d7cd'
+ '463dbccba0275ee80c532755c7048cb9ded83658a33a82f344aaf1520704f2ac'
+ '5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
+ '1c410e2e90f5cc1252c1a6915db080f9d5f8fb47fae4cc6e85b78ed3c3fb9d17'
+ '5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
+ 'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
+ '8ce994663d7588143ad7ed4441b07f468f4f7d3590164dd73ddfa3ea307ece8e'
+ 'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
+ '04dd4cbe5078f5181176ade3a82f333e3f48091b118360d69cc45a3526503818'
+ '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9')
package() {
- cd "$pkgdir"
-
- #
- # setup root filesystem
- #
- for d in boot dev etc home mnt usr var opt srv/http run; do
- install -d -m755 $d
- done
- install -d -m555 proc
- install -d -m555 sys
- install -d -m0750 root
- install -d -m1777 tmp
- # vsftpd won't run with write perms on /srv/ftp
- install -d -m555 -g ftp srv/ftp
-
- # setup /etc and /usr/share/factory/etc
- install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
- for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf passwd resolv.conf securetty shells profile; do
- install -m644 "$srcdir"/$f etc/
- install -m644 "$srcdir"/$f usr/share/factory/etc/
- done
- ln -s ../proc/self/mounts etc/mtab
- for f in gshadow shadow crypttab; do
- install -m600 "$srcdir"/$f etc/
- install -m600 "$srcdir"/$f usr/share/factory/etc/
- done
- touch etc/parabola-release
- ln -sv parabola-release etc/arch-release
- install -m755 "$srcdir"/locale.sh etc/profile.d/locale.sh
- install -Dm644 "$srcdir"/os-release "$pkgdir"/usr/lib/os-release
-
- # setup /var
- for d in cache local opt log/old lib/misc empty; do
- install -d -m755 var/$d
- done
- install -d -m1777 var/{tmp,spool/mail}
-
- # allow setgid games to write scores
- install -d -m775 -g games var/games
- ln -s spool/mail var/mail
- ln -s ../run var/run
- ln -s ../run/lock var/lock
-
- #
- # setup /usr hierarchy
- #
- for d in bin include lib share/misc src; do
- install -d -m755 usr/$d
- done
- for d in $(seq 8); do
- install -d -m755 usr/share/man/man$d
- done
-
- #
- # add lib symlinks
- #
- ln -s usr/lib "$pkgdir"/lib
- [[ $CARCH = 'x86_64' ]] && (
- ln -s usr/lib "$pkgdir"/lib64
- ln -s lib "$pkgdir"/usr/lib64
- )
-
- #
- # add bin symlinks
- #
- ln -s usr/bin "$pkgdir"/bin
- ln -s usr/bin "$pkgdir"/sbin
- ln -s bin "$pkgdir"/usr/sbin
-
- #
- # install parabola(7) manpage
- #
- install -D -m644 "$srcdir"/parabola.7 usr/share/man/man7/parabola.7
-
- #
- # setup /usr/local hierarchy
- #
- for d in bin etc games include lib man sbin share src; do
- install -d -m755 usr/local/$d
- done
- ln -s ../man usr/local/share/man
-
- # remove conflict with systemd
- rm usr/share/factory/etc/nsswitch.conf
+ cd "$pkgdir"
+
+ # setup root filesystem
+ for d in boot dev etc home mnt usr var opt srv/http run; do
+ install -d -m755 $d
+ done
+ install -d -m555 proc
+ install -d -m555 sys
+ install -d -m0750 root
+ install -d -m1777 tmp
+ # vsftpd won't run with write perms on /srv/ftp
+ # ftp (uid 14/gid 11)
+ install -d -m555 -g 11 srv/ftp
+
+ # setup /etc and /usr/share/factory/etc
+ install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
+ for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
+ passwd resolv.conf securetty shells profile; do
+ install -m644 "$srcdir"/$f etc/
+ install -m644 "$srcdir"/$f usr/share/factory/etc/
+ done
+ ln -s ../proc/self/mounts etc/mtab
+ for f in gshadow shadow crypttab; do
+ install -m600 "$srcdir"/$f etc/
+ install -m600 "$srcdir"/$f usr/share/factory/etc/
+ done
+ touch etc/parabola-release
+ ln -sv parabola-release etc/arch-release
+ install -m755 "$srcdir"/locale.sh etc/profile.d/locale.sh
+ install -Dm644 "$srcdir"/os-release usr/lib/os-release
+
+ # setup /var
+ for d in cache local opt log/old lib/misc empty; do
+ install -d -m755 var/$d
+ done
+ install -d -m1777 var/{tmp,spool/mail}
+
+ # allow setgid games (gid 50) to write scores
+ install -d -m775 -g 50 var/games
+ ln -s spool/mail var/mail
+ ln -s ../run var/run
+ ln -s ../run/lock var/lock
+
+ # setup /usr hierarchy
+ for d in bin include lib share/misc src; do
+ install -d -m755 usr/$d
+ done
+ for d in {1..8}; do
+ install -d -m755 usr/share/man/man$d
+ done
+
+ # add lib symlinks
+ ln -s usr/lib lib
+ [[ $CARCH = 'x86_64' ]] && {
+ ln -s usr/lib lib64
+ ln -s lib usr/lib64
+ }
+
+ # add bin symlinks
+ ln -s usr/bin bin
+ ln -s usr/bin sbin
+ ln -s bin usr/sbin
+
+ # setup /usr/local hierarchy
+ for d in bin etc games include lib man sbin share src; do
+ install -d -m755 usr/local/$d
+ done
+ ln -s ../man usr/local/share/man
+
+ # setup systemd-sysusers
+ install -D -m644 "$srcdir"/sysusers usr/lib/sysusers.d/parabola.conf
+ ln -sv parabola.conf usr/lib/sysusers.d/arch.conf
+
+ # setup systemd-tmpfiles
+ install -D -m644 "$srcdir"/tmpfiles usr/lib/tmpfiles.d/parabola.conf
+ ln -sv parabola.conf usr/lib/tmpfiles.d/arch.conf
+
+ # setup systemd.environment-generator
+ install -D -m755 "$srcdir"/env-generator usr/lib/systemd/system-environment-generators/10-arch
}