summaryrefslogtreecommitdiff
path: root/libre/filesystem/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2018-08-24 09:45:59 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2018-08-24 09:45:59 -0500
commite26369ed2a60af5f8e835166b04dd8f38d708f97 (patch)
tree7101019d8388196fd86a7d66a3de60cacdbac404 /libre/filesystem/PKGBUILD
parentc9abed706001bb445c817653e701d2f9c22f25f2 (diff)
filesystem-2018.8-1.parabola1: updating version
Diffstat (limited to 'libre/filesystem/PKGBUILD')
-rw-r--r--libre/filesystem/PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/libre/filesystem/PKGBUILD b/libre/filesystem/PKGBUILD
index c8429063c..b292769d4 100644
--- a/libre/filesystem/PKGBUILD
+++ b/libre/filesystem/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Nicolás Reynolds <fauno@kiwwwi.com.ar>
pkgname=filesystem
-pkgver=2018.1
-pkgrel=2.parabola3
+pkgver=2018.8
+pkgrel=1.parabola1
pkgdesc='Base Parabola GNU/Linux-libre files'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
@@ -21,7 +21,7 @@ backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
'etc/shadow' 'etc/shells')
source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
'issue' 'ld.so.conf' 'locale.sh' 'motd' 'nsswitch.conf' 'os-release'
- 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells'
+ 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells' 'sysctl'
'sysusers' 'tmpfiles')
sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
'ed0cb4f1db4021f8c3b5ce78fdf91d2c0624708f58f36c9cf867f4d93c3bc6da'
@@ -42,6 +42,7 @@ sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
'8ce994663d7588143ad7ed4441b07f468f4f7d3590164dd73ddfa3ea307ece8e'
'c390b31fffc4a2b5d78ae8c89f5317aadef1f71baac09cfb467b675db1406d61'
+ '89e43a0b7028f52d5c8e7fb961d962c4b4f4e9595880a6157274ddb2c7c0b6b4'
'04dd4cbe5078f5181176ade3a82f333e3f48091b118360d69cc45a3526503818'
'618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9')
@@ -115,6 +116,10 @@ package() {
done
ln -s ../man usr/local/share/man
+ # setup systemd-sysctl
+ install -D -m644 "$srcdir"/sysctl usr/lib/sysctl.d/10-parabola.conf
+ ln -sv 10-parabola.conf usr/lib/sysctl.d/10-arch.conf
+
# setup systemd-sysusers
install -D -m644 "$srcdir"/sysusers usr/lib/sysusers.d/parabola.conf
ln -sv parabola.conf usr/lib/sysusers.d/arch.conf
@@ -124,5 +129,6 @@ package() {
ln -sv parabola.conf usr/lib/tmpfiles.d/arch.conf
# setup systemd.environment-generator
- install -D -m755 "$srcdir"/env-generator usr/lib/systemd/system-environment-generators/10-arch
+ install -D -m755 "$srcdir"/env-generator usr/lib/systemd/system-environment-generators/10-parabola
+ ln -sv 10-parabola usr/lib/systemd/system-environment-generators/10-arch
}