summaryrefslogtreecommitdiff
path: root/libre/glib2-static/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-09 18:15:56 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-09 18:15:56 +0100
commit55e4a4402075a70457ac4d62865bf790325ef829 (patch)
tree2f4b6a5d001b126fb7be18b7257772de4c561d55 /libre/glib2-static/PKGBUILD
parenta7b90fdb57ef312f98974df2cfb3b50d2a39a90f (diff)
libre/glib2-static: updated to 2.58.3
Diffstat (limited to 'libre/glib2-static/PKGBUILD')
-rw-r--r--libre/glib2-static/PKGBUILD74
1 files changed, 23 insertions, 51 deletions
diff --git a/libre/glib2-static/PKGBUILD b/libre/glib2-static/PKGBUILD
index 4220009f2..f5a443408 100644
--- a/libre/glib2-static/PKGBUILD
+++ b/libre/glib2-static/PKGBUILD
@@ -3,29 +3,35 @@
# Contributor: Márcio Silva <coadde@hyperbola.info>
pkgname=glib2-static
-pkgver=2.56.1
-pkgrel=1.static1
+pkgver=2.58.3
+pkgrel=1
+pkgrel+=.static1
pkgdesc="Low level core library"
+pkgdesc+=" (static libraries)"
url="https://wiki.gnome.org/Projects/GLib"
license=(LGPL2.1)
arch=(x86_64)
arch+=(i686 armv7h)
depends=(pcre libffi libutil-linux zlib)
+depends+=("glib2=$pkgver")
_depends=(pcre-static libffi-static libutil-linux-static zlib)
-makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux dbus)
+makedepends=(gettext gtk-doc shared-mime-info python libelf git util-linux meson dbus)
makedepends+=("${_depends[@]}")
checkdepends=(desktop-file-utils)
optdepends=('python: gdbus-codegen, glib-genmarshal, glib-mkenums, gtester-report'
'libelf: gresource inspection tool')
options=(!emptydirs)
-_commit=d0364b443805dcb832c200fcf8bf58a64fdf3e7d # tags/2.56.1^0
+options+=(staticlibs)
+_commit=f2d1128ffae0de87680e411fb62ccfccafed6b1c # tags/2.58.3^0
source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
noisy-glib-compile-schemas.diff
glib-compile-schemas.hook gio-querymodules.hook)
+source+=(disable-dynamic-tests.patch)
sha256sums=('SKIP'
'81a4df0b638730cffb7fa263c04841f7ca6b9c9578ee5045db6f30ff0c3fc531'
'e1123a5d85d2445faac33f6dae1085fdd620d83279a4e130a83fe38db52b62b3'
- '5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6')
+ '5ba204a2686304b1454d401a39a9d27d09dd25e4529664e3fd565be3d439f8b6'
+ 'f4790fc845f2b4811ce5df5ef3a7dfcc23a1593ec4e19ae9173bb799a045d00f')
pkgver() {
cd glib
@@ -38,66 +44,32 @@ prepare() {
# Suppress noise from glib-compile-schemas.hook
patch -Np1 -i ../noisy-glib-compile-schemas.diff
- NOCONFIGURE=1 ./autogen.sh
+ # disable tests that fail on static builds
+ patch -Np1 -i ../disable-dynamic-tests.patch
}
build() {
- local debug=minimum
- check_option debug y && debug=yes
-
if [[ $CARCH = i686 ]]; then
# GTimer has trouble with x87 math, force SSE2 (which is implied
# on x86_64).
CFLAGS+=' -msse2 -mfpmath=sse'
fi
- cd glib
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --sysconfdir=/etc \
- --with-pcre=system \
- --enable-debug=$debug \
- --disable-gtk-doc \
- --disable-fam \
- --enable-static
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson glib build \
+ --default-library static \
+ -D selinux=false \
+ -D man=false \
+ -D gtk_doc=false
+ ninja -C build
}
check() {
- cd glib
- rm -rf "$srcdir/test-home"
- mkdir "$srcdir/test-home"
- HOME="$srcdir/test-home" make -j1 check
+ meson test -C build
}
package() {
- pkgdesc+=" (static libraries)"
- depends=("glib2=$pkgver")
- optdepends=()
- options=(staticlibs)
-
- cd glib
- make DESTDIR="$pkgdir" install
-
- rm -v -- "$pkgdir"/usr/lib/lib*.so*
- rm -vr -- \
- "$pkgdir"/usr/bin/ \
- "$pkgdir"/usr/include/ \
- "$pkgdir"/usr/lib/glib-*/ \
- "$pkgdir"/usr/lib/pkgconfig/ \
- "$pkgdir"/usr/share/
-}
-
-package_glib2-docs() {
- pkgdesc="Documentation for GLib"
- depends=()
- optdepends=()
- license+=(custom)
-
- mkdir -p "$pkgdir/usr/share"
- mv gtk-doc "$pkgdir/usr/share"
+ DESTDIR="$pkgdir" meson install -C build
- install -Dt "$pkgdir/usr/share/licenses/glib2-docs" -m644 glib/docs/reference/COPYING
+ # remove conflicting files
+ rm -rf "$pkgdir/usr/"{bin,include,share,lib/glib-2.0,lib/pkgconfig} $pkgdir/usr/lib/*.so*
}