summaryrefslogtreecommitdiff
path: root/libre/gnome-boxes/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 01:44:14 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2014-09-05 01:44:14 -0300
commit2728ded1e96eb209a37503f7838eef7c2aa29ee2 (patch)
tree06c0b7968ccbe920e3c9be593276d9dafad02f3e /libre/gnome-boxes/PKGBUILD
parent8cb075f1720b3a2febbc847279f39fe1602d7772 (diff)
gnome-boxes: remove libre suffix and add complex pkgrel
Diffstat (limited to 'libre/gnome-boxes/PKGBUILD')
-rw-r--r--libre/gnome-boxes/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/libre/gnome-boxes/PKGBUILD b/libre/gnome-boxes/PKGBUILD
new file mode 100644
index 000000000..b7c1579f9
--- /dev/null
+++ b/libre/gnome-boxes/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 113793 2014-06-30 13:59:38Z bgyorgy $
+# Maintainer (Arch): Balló György <ballogyor+arch at gmail dot com>
+# Contributor (Arch): Stefano Facchini <stefano.facchini@gmail.com>
+# Maintainer: André Silva <emulatorman@parabola.nu>
+# Contributor: Daniel Milewski <niitotantei@gmail.com>
+
+pkgname=gnome-boxes
+pkgver=3.12.3
+pkgrel=1.parabola1
+pkgdesc="Simple GNOME 3 application to access remote or virtual systems, without nonfree system logos"
+arch=('i686' 'x86_64' 'mips64el')
+url="https://wiki.gnome.org/Apps/Boxes"
+license=('LGPL')
+conflicts=(${pkgname}-libre)
+replaces=(${pkgname}-libre)
+depends=('clutter-gtk' 'gtk-vnc' 'libosinfo' 'libsoup' 'libvirt-glib' 'spice-gtk3'
+ 'libtracker-sparql' 'qemu' 'cdrkit' 'libcdio' 'mtools' 'dconf'
+ 'gnome-icon-theme' 'gnome-themes-standard')
+makedepends=('gobject-introspection' 'intltool' 'itstool' 'spice-protocol' 'vala')
+install=$pkgname.install
+source=(http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ libre.patch)
+sha256sums=('bf57525106baaa635d08a4a4c6ed81e4b8c8708897f2fe7c2623810aec9b6408'
+ '2a93935ba94b9f327645a92f11d1a3d23cbeab8e5c800e414c6762181f51d4c0')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ patch -Np1 -i "$srcdir/libre.patch"
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libexecdir=/usr/lib/$pkgname \
+ --disable-static --disable-schemas-compile --enable-smartcard
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}