summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-11-14 22:32:16 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2019-01-13 18:55:26 -0500
commit30e7f6c205c87344ed12840e9d00d346e123a381 (patch)
tree302d97add4b52f17f8ff8a531918bdac7e86e3a1 /libre/iceweasel/PKGBUILD
parentf728b4a05500686700a4d9618b0ccc233dde2a3a (diff)
libre/iceweasel: Update 61.0.2 → 63.0.1
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD65
1 files changed, 32 insertions, 33 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 635568990..46ebac8ec 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -19,7 +19,7 @@
# Contributor: evr <evanroman at gmail>
# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
-# Rational for inclusion in [libre]:
+# Rationale for inclusion in [libre]:
# - Modify the addons pages to use GNU IceCat plugins sources, rather
# than addons.mozilla.org, which hosts non-free addons.
# - Disable EME, which is implemented via the non-free libWideVine
@@ -29,29 +29,30 @@
# policy[1], so making those changes also requires us to:
# - Rebrand to Iceweasel
#
-# While we're at it, while not strictly nescessary for FSDG
+# While we're at it, while not strictly necessary for FSDG
# compliance:
# - Remove Google API keys and usage
# - Disable Mozilla telemetry and crash reporting (good manners
-# because of all of the other patching we're doing
+# because of all of the other patching we're doing)
#
# [1]: https://www.mozilla.org/en-US/foundation/trademarks/policy/
pkgname=iceweasel
replaces=('firefox')
epoch=1
-pkgver=61.0.2
+pkgver=63.0.1
pkgrel=1
-pkgrel+=.parabola4
+pkgrel+=.par1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
arch=(x86_64)
arch+=(i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
-depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2 python)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2
+ python nodejs python2-psutil cbindgen)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -59,34 +60,33 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
+ 0001-Keep-mozilla-release-building-with-newer-cbindgen-ve.patch
$pkgname.desktop)
+
+# Branding
+_brandingver='50e76939d930a072f76eea8d522422c29e49a251'
+makedepends+=(git mozilla-searchplugins quilt libxslt imagemagick)
+source+=("git://git.parabola.nu/packages/iceweasel.git#commit=${_brandingver}"
+ libre.patch)
+
sha256sums=('SKIP'
+ 'a1e523f830f28217e050991062358c91be254e21732a6391449a8c0e3e0de77f'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
- 'dabd5a0b8023e8ca13f6ae5fcb9e6c29531fc952bc781b4aa25c8a598187768e'
'SKIP'
- 'f2ebd5054b81a0f0f642b523a545145bdd5939e70b79c8129415cd1646cc6d74'
- '070f9e1a8513ab66903f2f19d6fa9d13c9a2d975921a21821a6e76cd8fec53c6'
'b695926b8a1f9560f0e11e0bad2ef42df6152d4f16f95af1027bc12c487c1ede')
-# Branding
-_brandingver=$(cut -d. -f1,2<<<"$pkgver")
-_brandingrel=1
-makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
-source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
- 0001-branding-Fix-for-v60-v61.patch
- 0002-Fix-triplet-two-parts.patch
- libre.patch)
-validpgpkeys+=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
-
prepare() {
+ mkdir mozbuild
cd mozilla-unified
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1503401
+ patch -Np1 -i ../0001-Keep-mozilla-release-building-with-newer-cbindgen-ve.patch
+
cat >.mozconfig <<END
ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
@@ -98,39 +98,34 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=nu.parabola
# System libraries
-ac_add_options --with-system-zlib
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-sqlite
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-sqlite
-ac_add_options --enable-system-ffi
+ac_add_options --with-system-zlib
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
+ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-eme
END
if [[ $CARCH = arm* ]]; then
- sed -i '/--enable-linker=gold/d' .mozconfig
cat >> .mozconfig <<- END
ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"
END
fi # end [[ $CARCH = arm* ]]
- patch -Np1 -i "$srcdir/0002-Fix-triplet-two-parts.patch"
-
## Rebranding
- local brandingdir="$srcdir/$pkgname-$_brandingver"
- pushd "$brandingdir"
- patch -Np1 -i "$srcdir/0001-branding-Fix-for-v60-v61.patch"
- popd
+ local brandingdir="$srcdir/$pkgname/src"
# file dump
rm -rf -- browser/branding/$pkgname
cp -aT -- $brandingdir/branding browser/branding/$pkgname
@@ -178,6 +173,8 @@ build() {
cd mozilla-unified
export MOZ_SOURCE_REPO="$_repo"
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
./mach build
./mach buildsymbols
@@ -551,3 +548,5 @@ END
ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/usr/lib/$pkgname/$pkgname-bin"
}
+
+# vim:set sw=2 et: