summaryrefslogtreecommitdiff
path: root/libre/mesa-demos/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-09-17 18:44:57 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-09-17 18:44:57 -0500
commit2373acf71afc4509e30de109d5fdac10d3a7711a (patch)
treeb27830b357dbbbdf4607220f9500455c8c466cc7 /libre/mesa-demos/PKGBUILD
parenta6a275ac4ee5a5a7abe72a87efe4ebe21400a125 (diff)
mesa-demos-8.3.0-4.parabola1: build with freetype2 support, add missing egl binaries
Diffstat (limited to 'libre/mesa-demos/PKGBUILD')
-rw-r--r--libre/mesa-demos/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/libre/mesa-demos/PKGBUILD b/libre/mesa-demos/PKGBUILD
index cd21fa68d..cfe3d0b37 100644
--- a/libre/mesa-demos/PKGBUILD
+++ b/libre/mesa-demos/PKGBUILD
@@ -1,19 +1,20 @@
# $Id: PKGBUILD 272747 2016-07-31 08:49:09Z andyrtr $
# Maintainer (Arch): Jan de Groot <jgc@archlinux.org>
# Maintainer (Arch): Andreas Radke <andyrtr@archlinux.org>
-# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname='mesa-demos'
pkgver=8.3.0
-pkgrel=2.parabola1
+pkgrel=4.parabola1
arch=('i686' 'x86_64' 'armv7h')
-pkgdesc="Mesa demos and tools, without nonfree demos"
+pkgdesc="Mesa demos and tools incl. glxinfo + glxgears, without nonfree demos"
url="http://mesa3d.sourceforge.net"
license=('custom')
replaces=('mesa-demos-libre')
conflicts=('mesa-demos-libre')
depends=('libgl' 'glew' 'freeglut')
-makedepends=('git')
+makedepends=('mesa' 'freetype2' 'git')
mksource=(ftp://ftp.freedesktop.org/pub/mesa/demos/$pkgver/mesa-demos-$pkgver.tar.bz2)
source=("https://repo.parabola.nu/other/mesa-demos-libre/mesa-demos-libre-${pkgver}.tar.bz2"
'LICENSE'
@@ -47,6 +48,10 @@ build() {
package() {
cd mesa-demos-$pkgver
make DESTDIR="${pkgdir}" install
+
+ # add missing egl files
+ install -m 0755 src/egl/opengl/{eglgears_x11,eglinfo,eglkms,egltri_x11,peglgears,xeglgears,xeglthreads} ${pkgdir}/usr/bin
+
install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
}