summaryrefslogtreecommitdiff
path: root/libre/qemu-static/PKGBUILD
diff options
context:
space:
mode:
authorcoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2016-05-07 14:00:19 -0300
committercoadde [Márcio Alexandre Silva Delgado] <coadde@parabola.nu>2016-05-07 14:06:48 -0300
commit1b1fcbe32b26022379c1670b9c8df2a42416e69b (patch)
treec737357c99c945bcddb072b60691d08750c33aca /libre/qemu-static/PKGBUILD
parent77a59464a716fd2242058977db02dc1303d8aba4 (diff)
libre/qemu-static: separate more qemu-static.conf
Diffstat (limited to 'libre/qemu-static/PKGBUILD')
-rw-r--r--libre/qemu-static/PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/libre/qemu-static/PKGBUILD b/libre/qemu-static/PKGBUILD
index 2944c4c09..35dd85938 100644
--- a/libre/qemu-static/PKGBUILD
+++ b/libre/qemu-static/PKGBUILD
@@ -11,11 +11,14 @@ license=('GPL2' 'LGPL2.1')
url='http://wiki.qemu.org/'
makedepends=('pixman-static' 'glib2-static' 'pcre-static' 'python2')
source=(http://wiki.qemu.org/download/${pkgbase}-${pkgver}.tar.bz2
- qemu-static-{arm,mips,x86}.conf)
+ qemu-static-{aarch64,arm,i386,mips,mips64,x86_64}.conf)
md5sums=('42e73182dea8b9213fa7050e168a4615'
- '77d5c2e9701f5e1853d9bfd2ef71182a'
- '551ec0a682887406f952634fb46b7d36'
- '0edd65932dbdec2a5951b9ad88eadcef')
+ '2967ebd9a45bcdc0b8863d65313ca569'
+ 'ae201d541b12a0f1cbab7206f26eef6e'
+ '86e0a86b9e3c851e014a9af0d5c4b80d'
+ 'bcac9d3466ec6b97cea3675536cea0c7'
+ '8088880bd092304f57864832137e8b1d'
+ 'b485e55f966e563b3dcc292b0afa4a61')
_extra_arches=(aarch64 alpha arm armeb cris m68k microblaze microblazeel
or32 ppc ppc64 ppc64abi32 ppc64le s390x tilegx
@@ -100,12 +103,14 @@ package_qemu-arch-extra-static() {
install -m755 ${_arch}-*/qemu-${_arch} "${pkgdir}"/usr/bin
mv -v "${pkgdir}"/usr/bin/qemu-${_arch}{,-static}
done
- if [[ $CARCH = x86_64 || $CARCH = i686 ]]; then
- install -m755 "${srcdir}"/qemu-static-x86.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
+ if [[ $CARCH = x86_64 ]]; then
+ install -m755 "${srcdir}"/qemu-static-x86_64.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
+ elif [[ $CARCH = i686 ]]; then
+ install -m755 "${srcdir}"/qemu-static-i386.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
elif [[ $CARCH = armv7h ]]; then
install -m755 "${srcdir}"/qemu-static-arm.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
elif [[ $CARCH = mips64el ]]; then
- install -m755 "${srcdir}"/qemu-static-mips.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
+ install -m755 "${srcdir}"/qemu-static-mips64.conf "${pkgdir}"/etc/binfmt.d/qemu-static.conf
fi
# manually stripping