summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2019-02-18 02:11:22 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2019-02-18 02:11:22 -0500
commit9320730ec7d9f3808114ab4fedc750d87aa29a16 (patch)
tree6a8cc443dc37a22c1a78ce20e7790c4b62c5a868 /libre/syslinux/PKGBUILD
parentee06a5f8b9001ee514c7c4c3f692e069654855f2 (diff)
syslinux-6.04.pre1.r41.g5e426532-1.par1: updating version
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD85
1 files changed, 34 insertions, 51 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index a564f0fa7..1549ffb22 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -6,9 +6,11 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=syslinux
-pkgver=6.03
-_tag=syslinux-$pkgver
-pkgrel=10.parabola1
+pkgver=6.04.pre1.r41.g5e426532
+#_tag=syslinux-$pkgver
+_commit=5e426532210bb830d2d7426eb8d8c154d9dfcba6
+pkgrel=1
+pkgrel+=.par1
pkgdesc='Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)'
url='http://www.syslinux.org/'
arch=(i686 x86_64)
@@ -33,69 +35,47 @@ optdepends=('perl-crypt-passwdmd5: For md5pass'
# The syslinux-install_update script is maintained at https://gist.github.com/pyther/772138
# Script not yet updated for syslinux-efi
-source=(git://git.kernel.org/pub/scm/boot/syslinux/syslinux.git#tag=$_tag
- git://git.code.sf.net/p/gnu-efi/code#commit=ab54e2b40e914d0ca01dc3d44c8d4eb8517bf999
+source=(git+https://repo.or.cz/syslinux.git#commit=$_commit
+ gnu-efi::git://git.code.sf.net/p/gnu-efi/code
syslinux.cfg
syslinux-install_update
- btrfs-fix.patch::http://repo.or.cz/syslinux.git/patch/548386049cd41e887079cdb904d3954365eb28f3?hp=721a0af2f0ba111c31685c5f6c5481eb25346971
- gcc-fix-alignment.patch::http://repo.or.cz/syslinux.git/patch/e5f2b577ded109291c9632dacb6eaa621d8a59fe?hp=8dc6d758b564a1ccc44c3ae11f265d43628219ce
- dont-guess-alignment.patch::http://repo.or.cz/syslinux.git/patch/0cc9a99e560a2f52bcf052fd85b1efae35ee812f?hp=e5f2b577ded109291c9632dacb6eaa621d8a59fe
- kdb-230.patch::http://repo.or.cz/syslinux.git/patch/138e850fab106b5235178848b3e0d33e25f4d3a2
- correct_base_type.patch::http://repo.or.cz/syslinux.git/patch/83aad4f
- set_mode_base.patch::http://repo.or.cz/syslinux.git/patch/0a2dbb3
- fix_return_pointer.patch::http://repo.or.cz/syslinux.git/patch/8dc6d758b564a1ccc44c3ae11f265d43628219ce
- support-ext4-64bit.patch::http://repo.or.cz/syslinux.git/patch/af7e95c32cea40c1e443ae301e64b27f068b4915
- fix_infinite_loop_tests.patch
- gnu-efi-git.patch
+ strip_note_section.patch
+ single-load-segment.patch
splash.png)
sha1sums=('SKIP'
'SKIP'
'e40acf4cf9d05ec000c59284f959d1540b35a3be'
'df5160a138ca8c6502d67fe1a64fec78b50e82c2'
- '6ebf77bf028c928a6ef33dadeee7402b3113b6d3'
- 'eaa9f5cd82b501f076ece4812d2d37f49d02caae'
- 'c6a6e96e233b2f8105503725cd614abc1bac2845'
- 'f50e0a92c65536ef73a84614d489e52d9d1db329'
- 'e24bf5b1617bab4a3f46925c5a8ee6079f4686bf'
- '500c174fce91133d40024b28f6f5cedb144b84c2'
- 'b3d2196aaec154749c5b796c6d9bfd605a918cf8'
- 'fe3ab41235aa57259bb6af8cc30c5877c1d8fb57'
- '7ecb02550666dfafeb0b22a67dcc34caa4b79767'
- '324af118594e6fb0864ef4905ce47d95c4d8e6ef'
+ '11d928087764ca286af0327d40230f219348568c'
+ '830c88005fb6c9e759f67b91ab33a10b002385de'
'aab1c7789e0d7290fe87538abad181abac069d40')
+sha256sums=('SKIP'
+ 'SKIP'
+ '67fe3050e60a0d1572293ff095dac2e6cab9da6d0f98fb1fc555850ec046d6ea'
+ '5f86b5813465c48ba7bd178389aacb5149ff0b5f2467ab1772a4f862c5b15d41'
+ '80d783fad7f96077a17634a6b17d8b7750a443221584aa802c096434bdaed603'
+ '0ba5667654ecd5b94c1941c7dce7ce945059b1fa70467f6f5a8770a959fcf82b'
+ 'a839e3e1242c5279f95f5f913af47be73cf16339c7aa55af378a428c904f1595')
+
_targets='bios efi32'
case "$CARCH" in
x86_64) _targets+=' efi64' ;;
esac
-prepare() {
+pkgver() {
cd syslinux
+ git describe --long | sed 's/^syslinux-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
- # FS#48253
- patch -p1 < ../gcc-fix-alignment.patch
- patch -p1 < ../dont-guess-alignment.patch
-
- # FS#48214
- patch -p1 < ../btrfs-fix.patch
-
- # FS#49046
- patch -p1 < ../kdb-230.patch
-
- # FS#53083
- patch -p1 < ../correct_base_type.patch
- patch -p1 < ../set_mode_base.patch
-
- # FS#49250
- patch -p1 < ../fix_return_pointer.patch
-
- # fix infinite loop in load_linux
- patch -p1 < ../fix_infinite_loop_tests.patch
+prepare() {
+ cd syslinux
- # FS#58137
- patch -p1 < ../support-ext4-64bit.patch
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414
+ patch -p1 < ../strip_note_section.patch
- patch -p1 < ../gnu-efi-git.patch
+ # https://bugs.archlinux.org/task/61059
+ patch -p1 < ../single-load-segment.patch
# do not swallow efi compilation output to make debugging easier
sed 's|> /dev/null 2>&1||' -i efi/check-gnu-efi.sh
@@ -103,8 +83,9 @@ prepare() {
# disable debug and development flags to reduce bootloader size
truncate --size 0 mk/devel.mk
- mkdir -p gnu-efi
- cp -rv $srcdir/code/gnu-efi-3.0 gnu-efi
+ git submodule init
+ git config --local submodule.gnu-efi.url "$srcdir/gnu-efi"
+ git submodule update
}
build() {
@@ -116,7 +97,9 @@ build() {
check() {
cd syslinux
- make unittest
+ # tests fail to compile
+ # make unittest
+ true
}
package() {