summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-08-12 15:08:54 -0300
committerAndré Fabian Silva Delgado <emulatorman@lavabit.com>2012-08-12 15:08:54 -0300
commitc0397909802567bce7228488890467d54a6cb415 (patch)
tree69583d9b28e3d3e9f924e1b577be74b83d03e114 /libre/syslinux/PKGBUILD
parenta3e2b8b1185c0e487600584e470b98a7f03c6e93 (diff)
syslinux-4.05-6: updating version
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index 6269ae93c..608316be1 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=syslinux
pkgver=4.05
-pkgrel=5
+pkgrel=6
arch=('i686' 'x86_64')
pkgdesc="Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)"
url="http://syslinux.zytor.com/"
@@ -13,7 +13,8 @@ depends=('perl' 'glibc')
optdepends=('perl-passwd-md5: For md5pass'
'perl-digest-sha1: For sha1pass'
'mtools: For mkdiskimage and syslinux support'
- 'gptfdisk: For GPT support')
+ 'gptfdisk: For GPT support'
+ 'util-linux: For isohybrid')
makedepends=('nasm')
backup=('boot/syslinux/syslinux.cfg'
'boot/syslinux/splash.png')
@@ -23,6 +24,7 @@ source=(http://www.kernel.org/pub/linux/utils/boot/syslinux/$pkgname-${pkgver}.t
syslinux.cfg
syslinux-install_update
avoid-using-ext2_fs.patch
+ handle-ctors-dtors-via-init_array-and-fini_array.patch
splash.png)
build() {
@@ -33,6 +35,8 @@ build() {
patch -p1 -i "$srcdir"/syslinux-dont-build-dos-windows-targets.patch
# fix #30084
patch -Np1 -i "$srcdir"/avoid-using-ext2_fs.patch
+ # fix #31065 (booting breaks with gcc 4.7)
+ patch -Np1 -i "$srcdir"/handle-ctors-dtors-via-init_array-and-fini_array.patch
# Fix FHS manpage path
sed 's|/usr/man|/usr/share/man|g' -i mk/syslinux.mk
make
@@ -51,10 +55,12 @@ package() {
install -D -m755 "$srcdir"/syslinux-install_update "$pkgdir"/usr/sbin/syslinux-install_update
# move extlinux binary to /usr/sbin
mv "$pkgdir"/sbin/extlinux "$pkgdir"/usr/sbin/extlinux
+ rmdir "$pkgdir"/sbin
}
md5sums=('82299242418385da1274c9479a778cb2'
'1528c376e43f0eaccaa80d8ad1bc13b4'
'8dc2afca3739667e892faf04eb97e7b1'
'680750f73dc2e587ac567d057d485813'
'2e2c674a71c0c0bf265d96cfc19ce985'
+ '12a2dbd3fe59230df2f470600dd62dac'
'0035b6cac6756a384b861eda8d33e4f7')