summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-03-02 14:43:34 -0300
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2017-03-02 16:25:44 -0300
commitc699e01ac42122f3d8d67b928dd608bad5b2862c (patch)
treed0049e4774c03f4bcb64000f58e90ac9ebb73482 /libre/syslinux/PKGBUILD
parent54a07bc0b21be2ff4cbe07dea38adf106eef959e (diff)
syslinux-6.03-7.parabola1: pull upstream patches to make syslinux bootable with recent Linux-libre kernel at Chromebooks - FS#53083 -> https://bugs.archlinux.org/task/53083
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index f22284243..a7b43c190 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=syslinux
pkgver=6.03
_tag=syslinux-$pkgver
-pkgrel=6.parabola1
+pkgrel=7.parabola1
pkgdesc='Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)'
url='http://www.syslinux.org/'
arch=(i686 x86_64)
@@ -25,7 +25,7 @@ if [[ "$CARCH" == x86_64 ]]; then
# efi32 needs it
makedepends+=(lib32-glibc)
fi
-optdepends=('perl-passwd-md5: For md5pass'
+optdepends=('perl-crypt-passwdmd5: For md5pass'
'perl-digest-sha1: For sha1pass'
'mtools: For mkdiskimage and syslinux support'
'gptfdisk: For GPT support'
@@ -42,14 +42,18 @@ source=(git://git.kernel.org/pub/scm/boot/syslinux/syslinux.git#tag=$_tag
gcc-fix-alignment.patch::http://repo.or.cz/syslinux.git/patch/e5f2b577ded109291c9632dacb6eaa621d8a59fe?hp=8dc6d758b564a1ccc44c3ae11f265d43628219ce
dont-guess-alignment.patch::http://repo.or.cz/syslinux.git/patch/0cc9a99e560a2f52bcf052fd85b1efae35ee812f?hp=e5f2b577ded109291c9632dacb6eaa621d8a59fe
kdb-230.patch::http://repo.or.cz/syslinux.git/patch/138e850fab106b5235178848b3e0d33e25f4d3a2
+ correct_base_type.patch::http://repo.or.cz/syslinux.git/patch/83aad4f
+ set_mode_base.patch::http://repo.or.cz/syslinux.git/patch/0a2dbb3
splash.png)
sha1sums=('SKIP'
'e40acf4cf9d05ec000c59284f959d1540b35a3be'
- '29d7c28639e57cdaefc8ef2447e8412a7b59709d'
+ '2cf5a0eccfb0bf4196b8aea4add1002be948332d'
'3e7d6e399c25fb7f5d31cc8e580d01163695e351'
'74b976dd3ce28a619c2e9ef69a33fd455dc4bd4c'
'b6ef5a7cdd4b7c714fd78c174e93ae6e854ae1ee'
'370b4bd392361d3fbc4a10f057d69c737acabd8a'
+ '6fdd0ebd6c34e4a424982e29beacff0a16e50c02'
+ 'd3551c17674ea51f3457a05ec1136604349fb89e'
'aab1c7789e0d7290fe87538abad181abac069d40')
_targets='bios efi32'
@@ -70,6 +74,10 @@ prepare() {
# FS#49046
patch -p1 < ../kdb-230.patch
+ # FS#53083
+ patch -p1 < ../correct_base_type.patch
+ patch -p1 < ../set_mode_base.patch
+
# do not swallow efi compilation output to make debugging easier
sed 's|> /dev/null 2>&1||' -i efi/check-gnu-efi.sh