summaryrefslogtreecommitdiff
path: root/libre/systemd/PKGBUILD
diff options
context:
space:
mode:
authorOmar Vega Ramos <ovruni@gnu.org.pe>2017-10-22 23:48:00 -0500
committerOmar Vega Ramos <ovruni@gnu.org.pe>2017-10-22 23:48:00 -0500
commit21f47999701f8fe095e5b81274c64bf80e01e541 (patch)
treedae299c40aaa2b11e6a84fe37d3b0a750bf87208 /libre/systemd/PKGBUILD
parentf41a12c6e657cfecbafe553115581994b44db3e2 (diff)
systemd-235.8-1.parabola1: updating version
Diffstat (limited to 'libre/systemd/PKGBUILD')
-rw-r--r--libre/systemd/PKGBUILD42
1 files changed, 12 insertions, 30 deletions
diff --git a/libre/systemd/PKGBUILD b/libre/systemd/PKGBUILD
index 0455ea8ca..1bfef5d50 100644
--- a/libre/systemd/PKGBUILD
+++ b/libre/systemd/PKGBUILD
@@ -10,12 +10,12 @@ pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
_libsystemd=('libsystemd-standalone' 'libudev' 'nss-systemd' 'nss-myhostname' 'nss-mymachines' 'nss-resolve')
pkgname+=("${_libsystemd[@]}")
# latest commit on stable branch
-_commit='d52e2bb9c20216972754c054e8534bca28baab66'
+_commit='7ba74d5f939d0322d6ea730dd0b5ceefd7d7f527'
# Bump this to latest major release for signed tag verification,
# the commit count is handled by pkgver() function.
-pkgver=234.11
-pkgrel=8
-pkgrel+=.parabola3
+pkgver=235.8
+pkgrel=1
+pkgrel+=.parabola1
arch=('i686' 'x86_64')
arch+=('armv7h')
url="https://www.github.com/systemd/systemd"
@@ -27,8 +27,9 @@ makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
makedepends_i686=('gnu-efi-libs')
makedepends_x86_64=('gnu-efi-libs')
options=('strip')
-source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
- 'git://github.com/systemd/systemd.git' # pull in for tags
+validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4') # Lennart Poettering <lennart@poettering.net>
+source=('git://github.com/systemd/systemd-stable.git'
+ 'git://github.com/systemd/systemd.git' # pull in for tags, backports & reverts
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev'
@@ -50,7 +51,7 @@ source=("git://github.com/systemd/systemd-stable.git#commit=${_commit}"
sha512sums=('SKIP'
'SKIP'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
- 'a70a779828e03c91275df1e046f78bdface08e2a8df0245a3f6e8d5904e3dbbe5d498cbf7f32d5ce61f2fb0d0a3d440d47ce9e41352a5547d80fa1bc29687159'
+ '86d7cacd7536b1069c82bbbb08de7ec81e7f0f18a19fc2b06fabe90db4700623eb3540b75121080d325672d92e26912632ae4f93fd3c0bb48eb3e5eedd88352c'
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
'70b3f1d6aaa9cd4b6b34055a587554770c34194100b17b2ef3aaf4f16f68da0865f6b3ae443b3252d395e80efabd412b763259ffb76c902b60e23b6b522e3cc8'
'6c6f579644ea2ebb6b46ee274ab15110718b0de40def8c30173ba8480b045d403f2aedd15b50ad9b96453f4ad56920d1350ff76563755bb9a80b10fa7f64f1d9'
@@ -67,21 +68,8 @@ sha512sums=('SKIP'
'b45c4e40f626a02951a852ea4cd2304f00a172dc64b5c38a97f5c68e4a89ceb4f4164cc9221533c4a5c52662e0b9629a82c521514bfcc21f0c11ce517643c2c1'
'f5c4cbeecac8f9d8f009deb4ac1d0b797210bcd1a91fcc6bf8ec110320ad6ceb8fd2a28b184ca037d73078d09a22f224ad3fc46f4bbf972432cce23263b2e1dc'
'e276fd1aedd7718333324fa9d99493fe99d951f446e3b590a99e2cc9562a0bd0e29693907997cb52096c39168c5be62ded3feedf93bacd3c9659d58775b6ca8d')
-validpgpkeys=(
- '63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering
-)
_backports=(
- # cryptsetup: fix infinite timeout (#6486)
- '0864d311766498563331f486909a0d950ba7de87'
-
- # process-util: add getpid_cached() as a caching wrapper for getpid()
- '5c30a6d2b805ae9b5dd0ad003b9ee86b8965bc47'
- # tree-wide: make use of getpid_cached() wherever we can
- 'df0ff127758809a45105893772de76082d12a26d'
-
- # call chase_symlinks without the /sysroot prefix (#6411) (FS#54958)
- '98eda38aed6a10c4f6d6ad0cac6e5361e87de52b'
)
_reverts=(
@@ -130,6 +118,8 @@ prepare() {
git remote add upstream ../systemd/
git fetch --all
+ git checkout "${_commit}"
+
_validate_tag || return
local _commit
@@ -140,12 +130,6 @@ prepare() {
git revert -n "$_commit"
done
- # core: store the invocation ID in the per-service keyring
- # core: run each system service with a fresh session keyring
- git show 'b3415f5daef49642be3d5f417b8880c078420ff7' \
- '74dd6b515fa968c5710b396a7664cac335e25ca8' \
- -- . ':!src/test/test-id128.c' | git apply --reverse --index
-
# apply FSDG patches
local _patch
for _patch in "$srcdir"/????-FSDG-*.patch; do
@@ -163,9 +147,6 @@ build() {
fi
local meson_options=(
- --buildtype=release
- -Db_lto=true
-
-Daudit=false
-Dima=false
-Dlz4=true
@@ -185,7 +166,7 @@ build() {
meson_options+=(-Dgnuefi=true)
fi
- meson "$pkgbase-stable" build "${meson_options[@]}"
+ arch-meson "$pkgbase-stable" build "${meson_options[@]}"
ninja -C build
@@ -227,6 +208,7 @@ build() {
package_systemd() {
pkgdesc="system and service manager"
license=('GPL2' 'LGPL2.1')
+ groups=('base-devel')
depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
'libgcrypt' 'libsystemd' 'libidn' 'lz4' 'pam' 'libelf' 'libseccomp'
'util-linux' 'xz')