summaryrefslogtreecommitdiff
path: root/pcr/jitsi/PKGBUILD
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-03-23 06:19:39 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>2020-03-23 06:20:24 +0100
commit7dfdb4f73b033eac7ee250a9f374e398d1458166 (patch)
treed9cc2c27371e9b4c08b7e2f43fe9f354639b084b /pcr/jitsi/PKGBUILD
parentf267e86d9de73919e37cd2b89adfa286591de044 (diff)
jitsi: remove bundled binaries
According to the commits refencencing such libraries in the jitsi git, the libraries seem to have been optional at the beginning and have been introduced to improve performances. Running jitsi on the command line doesn't output errors that seem to be related to the removal of the libraries, while it does on architectures like armv7h that ended having x86 libraries being shipped. Note that compiled Java bytecode is present in jars, but removing all of them makes the build fail. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Diffstat (limited to 'pcr/jitsi/PKGBUILD')
-rw-r--r--pcr/jitsi/PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/pcr/jitsi/PKGBUILD b/pcr/jitsi/PKGBUILD
index c297d2e3d..74d1625aa 100644
--- a/pcr/jitsi/PKGBUILD
+++ b/pcr/jitsi/PKGBUILD
@@ -7,10 +7,11 @@
# - corrected used license
# - fixed build by removing the following line:
# . /etc/profile.d/apache-ant.sh
+# - removed bundled binaries
pkgname=jitsi
pkgver=2.10.5550
-pkgrel=8
+pkgrel=9
pkgdesc="An audio/video SIP VoIP phone and instant messenger written in Java (formerly SIP-Communicator)"
arch=('armv7h' 'i686' 'x86_64')
url="http://jitsi.org"
@@ -24,6 +25,11 @@ source=("https://download.jitsi.org/jitsi/src/jitsi-src-${pkgver}.zip"
sha256sums=('cdfc6f038d1b877c42d26dba1864ac7c6b554dd55c18767a29f2db3618647287'
'40a411ec494280490a0e1a137735ef5efca434d8d10f18b0124df9e93302f959'
'b22ae316fece079ce7f56060f79722d74867562ec12b9a5279d144eb359587c9')
+prepare()
+{
+ cd "${srcdir}/${pkgname}"
+ rm -rf lib/native
+}
build()
{
@@ -36,9 +42,7 @@ build()
package() {
cd "${srcdir}/${pkgname}"
find lib/ lib/bundle/ -maxdepth 1 -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/"{} \;
-# find lib/os-specific/linux/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/"{} \;
shopt -sq extglob
- find lib/native/linux$(sed 's/_/-/g' <<<${CARCH/#*(i?86|x86)/})/ -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/lib/native/"{} \;
find sc-bundles/{,os-specific/linux/} -maxdepth 1 -type f -execdir install -Dm644 {} "${pkgdir}/usr/lib/${pkgname}/sc-bundles/"{} \;
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"