summaryrefslogtreecommitdiff
path: root/pcr/python-isbnlib/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-25 17:41:58 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-25 17:44:35 +0100
commitbbc48be6dabc264bfd0a7a67b6904da4e05b7ea1 (patch)
tree99f04bb1063a2644f398b0937b1de19806f5d3fe /pcr/python-isbnlib/PKGBUILD
parent0c7866cd99f57bc6f097a120439b526ee2212798 (diff)
pcr/python-isbnlib: added
Diffstat (limited to 'pcr/python-isbnlib/PKGBUILD')
-rw-r--r--pcr/python-isbnlib/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/pcr/python-isbnlib/PKGBUILD b/pcr/python-isbnlib/PKGBUILD
new file mode 100644
index 000000000..72ed5f792
--- /dev/null
+++ b/pcr/python-isbnlib/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andreas Grapentin <oaken-source@parabola.nu>
+
+_pkgname=isbnlib
+pkgname=(python{,2}-$_pkgname)
+pkgver=3.9.6
+pkgrel=1
+pkgdesc='Extract, clean, transform, hyphenate and metadata for ISBNs'
+arch=(any)
+url="https://pypi.python.org/pypi/$_pyname"
+license=('LGPL3')
+
+_depends=()
+makedepends=(python{,2}-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('91771e51eefc5a2d11cc13774afec0e1')
+
+_package() {
+ depends=("$1" "${_depends[@]/#/$1-}")
+ cd "$srcdir"/$_pkgname-$pkgver
+ $1 setup.py install --root="$pkgdir"
+}
+
+for _pkg in "${pkgname[@]}"; do
+ eval "package_$_pkg () { _package ${_pkg%%-*}; }"
+done