summaryrefslogtreecommitdiff
path: root/pcr/python-poppler-qt5/PKGBUILD
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-07-20 03:40:48 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2020-07-20 03:50:53 -0400
commit6ac2b346269c961f52ed71e8c5fa669bbe0635a3 (patch)
tree6a274b12151a45eda53bbfec45f380f698ff3584 /pcr/python-poppler-qt5/PKGBUILD
parentebdb02eaa7e94ff5aa6b7a938412857f52c7e624 (diff)
[python-poppler-qt5]: upgrade to v0.75.0
Diffstat (limited to 'pcr/python-poppler-qt5/PKGBUILD')
-rw-r--r--pcr/python-poppler-qt5/PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/pcr/python-poppler-qt5/PKGBUILD b/pcr/python-poppler-qt5/PKGBUILD
index 781b6928c..7006ba00d 100644
--- a/pcr/python-poppler-qt5/PKGBUILD
+++ b/pcr/python-poppler-qt5/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer (AUR): Johan Reitan (venatux) <johan.reitan@gmail.com>
+# Maintainer (AUR): Caleb Maclennan <caleb@alerque.com>
+# Contributor (AUR): Lucki <https://aur.archlinux.org/account/Lucki/>
+# Contributor (AUR): Johan Reitan (venatux) <johan.reitan@gmail.com>
# Contributer (AUR): Kenneth Lyons (ixjlyons) <ixjlyons@gmail.com>
-# parabola changes and rationale:
-# no changes.
-
pkgname=python-poppler-qt5
-pkgver=0.25.1
-pkgrel=1
-pkgdesc='Python binding to libpoppler-qt5.'
+pkgver=0.75.0
+pkgrel=4
+pkgdesc='Python binding to libpoppler-qt5'
arch=('any')
-# url="https://github.com/wbsoft/${pkgname}"
-url="https://github.com/zehome/$pkgname"
+url="https://github.com/frescobaldi/$pkgname"
license=('LGPL')
depends=('python-pyqt5' 'poppler-qt5')
-makedepends=('python-sip-pyqt5' 'python-sip' 'sip' 'python-setuptools')
-# source=("https://github.com/wbsoft/${pkgname}/archive/v${pkgver}.tar.gz")
-source=("https://github.com/zehome/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('f3d0f649964872275bd8e5ac45b9a7915ca18a4b2a46de904cd920e2c67a8627')
+makedepends=('python-sip' 'sip' 'python-setuptools')
+source=($pkgname-$pkgver.tar.gz::https://github.com/frescobaldi/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('92e6bd8f4ce90ba4e3e0c2ada026b643481ba1b109d45e8fdbdaedca8416a995')
+
+build() {
+ cd "$pkgname-$pkgver"
+ # python setup.py build
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ python setup.py build_ext --pyqt-sip-dir="$site_packages"/PyQt5/bindings/
+}
package() {
cd "$pkgname-$pkgver"