summaryrefslogtreecommitdiff
path: root/pcr/python-slugify/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-02-25 17:41:18 +0100
committerAndreas Grapentin <andreas@grapentin.org>2019-02-25 17:44:35 +0100
commitda044bd29113895d2691fc7ec091beba43dc6cb2 (patch)
tree45994fc57d0d2b052632e02f10e6b6d78d123dfd /pcr/python-slugify/PKGBUILD
parent12252d3e85c22c6f17459f0a0cd79b873d74c77a (diff)
pcr/python-slugify: updated to 2.0.1
Diffstat (limited to 'pcr/python-slugify/PKGBUILD')
-rw-r--r--pcr/python-slugify/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/pcr/python-slugify/PKGBUILD b/pcr/python-slugify/PKGBUILD
index 5a23850e4..e86c824d4 100644
--- a/pcr/python-slugify/PKGBUILD
+++ b/pcr/python-slugify/PKGBUILD
@@ -1,22 +1,25 @@
+# Maintainer: Andreas Grapentin <oaken-source@parabola.nu>
_pkgname=python-slugify
-pkgname=(python-${_pkgname#python-} python2-${_pkgname#python-})
-pkgver=1.2.5
+pkgname=(python{,2}-${_pkgname#python-})
+pkgver=2.0.1
pkgrel=1
pkgdesc="A Python Slugify application that handles Unicode"
-arch=('any')
+arch=(any)
url="https://pypi.python.org/pypi/$_pkgname"
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/70/c1/98bfb2c981787dcec4613c5da2c17d6f54613935b0e3a877e87a9fa974e4/$_pkgname-$pkgver.tar.gz")
-sha256sums=('5dbb360b882b2dabe0471a1a92f604504d83c2a73c71f2098d004ab62e695534')
-_package(){
- depends=($1)
+_depends=()
+makedepends=(python{,2}-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('4e2fd2c958b87d28e1cafaf2156ef83e')
+
+_package() {
+ depends=("$1" "${_depends[@]/#/$1-}")
cd "$srcdir"/$_pkgname-$pkgver
$1 setup.py install --root="$pkgdir"
}
-for pkg in "${pkgname[@]}"; do
- eval "package_$pkg () { _package ${pkg%%-*}; }"
+for _pkg in "${pkgname[@]}"; do
+ eval "package_$_pkg () { _package ${_pkg%%-*}; }"
done