summaryrefslogtreecommitdiff
path: root/cross/cross-binutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-binutils/PKGBUILD')
-rw-r--r--cross/cross-binutils/PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/cross/cross-binutils/PKGBUILD b/cross/cross-binutils/PKGBUILD
index 837ad0e6c..9eef49ede 100644
--- a/cross/cross-binutils/PKGBUILD
+++ b/cross/cross-binutils/PKGBUILD
@@ -125,7 +125,7 @@ fi
_pkgname=binutils
pkgname=$_target-$_pkgname
pkgver=2.24
-pkgrel=7
+pkgrel=7.1
pkgdesc="A set of programs to assemble and manipulate binary and object files"
arch=('i686' 'x86_64' 'mips64el')
url="http://www.gnu.org/software/$_pkgname/"
@@ -168,12 +168,20 @@ prepare() {
build() {
cd ${srcdir}/$_pkgname-build
- ${srcdir}/$_pkgname-${pkgver}/configure --prefix=/usr \
- --with-lib-path=/usr/lib:/usr/local/lib \
- --with-bugurl=https://labs.parabola.nu/ \
- --enable-threads --enable-shared --with-pic \
- --enable-ld=default --enable-gold --enable-plugins \
- --disable-werror --target=$_target --program-prefix=$_target-
+ if [[ $_target == xtensa-unknown-elf ]]; then
+ ${srcdir}/$_pkgname-${pkgver}/configure --prefix=/usr \
+ --with-lib-path=/usr/lib:/usr/local/lib \
+ --with-bugurl=https://labs.parabola.nu/ \
+ --enable-shared --disable-nls \
+ --disable-werror --disable-multilib --target=$_target --program-prefix=$_target-
+ else
+ ${srcdir}/$_pkgname-${pkgver}/configure --prefix=/usr \
+ --with-lib-path=/usr/lib:/usr/local/lib \
+ --with-bugurl=https://labs.parabola.nu/ \
+ --enable-threads --enable-shared --with-pic \
+ --enable-ld=default --enable-gold --enable-plugins \
+ --disable-werror --target=$_target --program-prefix=$_target-
+ fi
# check the host environment and makes sure all the necessary tools are available
make configure-host