summaryrefslogtreecommitdiff
path: root/cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD')
-rw-r--r--cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD292
1 files changed, 0 insertions, 292 deletions
diff --git a/cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD b/cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD
deleted file mode 100644
index 975db9f9d..000000000
--- a/cross/mips64el-unknown-linux-gnu-gcc/PKGBUILD
+++ /dev/null
@@ -1,292 +0,0 @@
-# $Id: PKGBUILD 145914 2012-01-04 01:24:56Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-
-# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
-# NOTE: libtool requires rebuilt with each new gcc version
-_pkgname=gcc
-_target="mips64el-unknown-linux-gnu"
-_sysroot="/usr/${_target}"
-_ARCH=mips
-
-unset LDFLAGS CFLAGS CXXFLAGS
-
-# Split package names must be changed manually
-pkgname=("${_target}-gcc" "${_target}-gcc-libs" "${_target}-gcc-fortran" "${_target}-gcc-objc") # "gcc-ada" "gcc-go")
-pkgver=4.6.2
-pkgrel=5
-_snapshot=4.6-20111223
-_libstdcppmanver=20111215 # Note: check source directory name when updating this
-pkgdesc="The GNU Compiler Collection for MIPS/Loongson2f processors"
-arch=('i686' 'x86_64')
-license=('GPL' 'LGPL' 'FDL' 'custom')
-url="http://gcc.gnu.org"
-makedepends=("${_target}-binutils>=2.22" "libmpc" "cloog" "ppl"
- "cross-${_target}-gcc-core-shared"
- "${_target}-glibc")
-checkdepends=('dejagnu')
-options=('!libtool' '!emptydirs' '!strip')
-source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-man.${_libstdcppmanver}.tar.bz2
- gcc_pure64.patch
- gcc_mips64el_lib.patch
- gcc-hash-style-both.patch)
-
-if [ -n "${_snapshot}" ]; then
- _basedir="${srcdir}/gcc-${_snapshot}"
-else
- _basedir="${srcdir}/gcc-${pkgver}"
-fi
-
-build() {
- if [ ${NOEXTRACT} -eq 0 ]; then
- cd ${_basedir}
-
- # Do not install libiberty
- sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
-
- # Do not run fixincludes
- sed -i 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
-
- if [ "${CARCH}" = "x86_64" ]; then
- patch -Np1 -i ${srcdir}/gcc_pure64.patch
- fi
- patch -Np0 -i ${srcdir}/gcc-hash-style-both.patch
- patch -Np0 -i ${srcdir}/gcc_mips64el_lib.patch
-
- echo ${pkgver} > gcc/BASE-VER
-
- mkdir ${srcdir}/gcc-build
- fi
-
- cd ${srcdir}/gcc-build
-
- CC_FOR_BUILD=${CHOST}-gcc \
- CFLAGS=" -pipe " \
- LDFLAGS= \
- CFLAGS_FOR_TARGET=" -EL -march=loongson2f -mabi=n32 " \
- CXXFLAGS_FOR_TARGET=" -EL -march=loongson2f -mabi=n32 " \
- LDFLAGS_FOR_TARGET=" -EL " \
- ${_basedir}/configure --prefix=/usr \
- --build=${CHOST} \
- --host=${CHOST} \
- --target=${_target} \
- --libexecdir=/usr/lib \
- --with-sysroot=${_sysroot} \
- --with-arch=loongson2f \
- --with-abi=n32 \
- --with-bugurl=https://bugs.parabolagnulinux.org/ \
- --enable-languages=c,c++,fortran,lto,objc,obj-c++ \
- --enable-shared \
- --enable-threads=posix \
- --with-system-zlib \
- --enable-__cxa_atexit \
- --disable-libunwind-exceptions \
- --enable-clocale=gnu \
- --enable-gnu-unique-object \
- --enable-linker-build-id \
- --with-ppl \
- --enable-cloog-backend=isl \
- --enable-lto \
- --enable-gold \
- --enable-ld=default \
- --enable-plugin \
- --with-plugin-ld=ld.gold \
- --disable-multilib \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --enable-checking=release
-
- make
-}
-
-check() {
- cd gcc-build
-
- # increase stack size to prevent test failures
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=31827
- ulimit -s 32768
-
- # do not abort on error as some are "expected"
- make -k check || true
- ${_basedir}/contrib/test_summary
-}
-
-
-package_mips64el-unknown-linux-gnu-gcc-libs()
-{
- pkgdesc="Runtime libraries shipped by GCC"
- groups=("${_target}-devel")
- depends=("${_target}-glibc>=2.14")
- install=gcc-libs.install
-
- cd gcc-build
- make -j1 -C ${_target}/libgcc DESTDIR=${pkgdir} install-shared
- for lib in libmudflap libgomp libstdc++-v3/src; do
- make -j1 -C $_target/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
- done
- make -j1 -C $_target/libstdc++-v3/po DESTDIR=${pkgdir} install
- make -j1 -C $_target/libgomp DESTDIR=${pkgdir} install-info
-
- make -j1 DESTDIR=${pkgdir} install-target-libquadmath
- make -j1 DESTDIR=${pkgdir} install-target-libgfortran
- make -j1 DESTDIR=${pkgdir} install-target-libobjc
-
- # remove unnecessary files installed by install-target-{libquadmath,libgfortran,libobjc}
- rm -rf ${pkgdir}${_sysroot}/usr/lib{,32}/{gcc/,libgfortran.spec}
-
- rm -rf ${pkgdir}/usr/share
-
- # remove static libraries
- find ${pkgdir} -name *.a -delete
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/${_target}-gcc-libs/RUNTIME.LIBRARY.EXCEPTION
-}
-
-package_mips64el-unknown-linux-gnu-gcc()
-{
- pkgdesc="The GNU Compiler Collection - C and C++ frontends"
- depends=("${_target}-gcc-libs=$pkgver-$pkgrel" "${_target}-binutils>=2.22" 'libmpc' 'cloog' 'ppl')
- groups=("${_target}-devel")
- replaces=("cross-${_target}-gcc-core"
- "cross-${_target}-gcc-core-shared")
- install=gcc.install
-
- cd gcc-build
-
- # unfortunately it is much, much easier to install the lot and clean-up the mess...
- make -j1 DESTDIR=${pkgdir} install
-
- rm -rf ${pkgdir}/usr/share
-
- rm -f $pkgdir/usr/bin/{{$_target-,}gfortran,{$_target-,}gccgo,gnat*}
- rm -f $pkgdir${_sysroot}/lib{,32}/*.so*
- rm -f $pkgdir${_sysroot}/lib{,32}/lib{ffi,gfortran,go{,begin},objc,quadmath}.a
- rm -f $pkgdir${_sysroot}/lib{,32}/libgfortran.spec
- rm -rf $pkgdir/usr/lib{,32}/gcc/$_target/${pkgver}/{ada{include,lib},finclude,include/objc}
- rm -f $pkgdir/usr/lib{,32}/gcc/$_target/${pkgver}/include/{ffi{,target}.h,quadmath{,_weak}.h}
- rm -f $pkgdir/usr/lib{,32}/gcc/$_target/${pkgver}/{cc1obj{,plus},f951,gnat1,go1,libgfortranbegin.a}
- rm -rf $pkgdir/usr/lib{,32}/go
-
- # many packages require these symlinks
- install -dm755 ${pkgdir}/lib
-
- ln -sf /usr/bin/cpp ${pkgdir}/lib/${_target}-cpp
- ln -sf ${_target}-gcc ${pkgdir}/usr/bin/${_target}-cc
- ln -sf ${_target}-g++ ${pkgdir}/usr/bin/${_target}-c++
-
- # install gengtype for plugin support
- install -m755 gcc/build/gengtype $pkgdir/usr/lib/gcc/$_target/${pkgver}/
- install -m644 gcc/gtype.state $pkgdir/usr/lib/gcc/$_target/${pkgver}/
-
- # POSIX conformance launcher scripts for c89 and c99
- cat > $pkgdir/usr/bin/${_target}-c89 <<"EOF"
-#!/bin/sh
-fl="-std=c89"
-for opt; do
- case "$opt" in
- -ansi|-std=c89|-std=iso9899:1990) fl="";;
- -std=*) echo "`basename $0` called with non ANSI/ISO C option $opt" >&2
- exit 1;;
- esac
-done
-exec mips64el-unknown-linux-gnu-gcc $fl ${1+"$@"}
-EOF
-
- cat > $pkgdir/usr/bin/${_target}-c99 <<"EOF"
-#!/bin/sh
-fl="-std=c99"
-for opt; do
- case "$opt" in
- -std=c99|-std=iso9899:1999) fl="";;
- -std=*) echo "`basename $0` called with non ISO C99 option $opt" >&2
- exit 1;;
- esac
-done
-exec mips64el-unknown-linux-gnu-gcc $fl ${1+"$@"}
-EOF
-
- chmod 755 $pkgdir/usr/bin/${_target}-c{8,9}9
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/${_target}-gcc/RUNTIME.LIBRARY.EXCEPTION
-}
-
-package_mips64el-unknown-linux-gnu-gcc-fortran()
-{
- pkgdesc="Fortran front-end for GCC"
- depends=("${_target}-gcc=$pkgver-$pkgrel")
- install=gcc-fortran.install
-
- cd gcc-build
- make -j1 DESTDIR=${pkgdir} install-target-libquadmath
- make -j1 DESTDIR=$pkgdir install-target-libgfortran
- make -j1 -C $_target/libgomp DESTDIR=$pkgdir install-nodist_fincludeHEADERS
- make -j1 -C gcc DESTDIR=$pkgdir fortran.install-{common,man,info}
- install -Dm755 gcc/f951 $pkgdir/usr/lib/gcc/$_target/$pkgver/f951
-
- # remove libraries included in gcc-libs
- rm -f ${pkgdir}${_sysroot}/lib{,32}/lib{gfortran,quadmath}.so*
- rm -fr ${pkgdir}/usr/share
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/${_target}-gcc-fortran/RUNTIME.LIBRARY.EXCEPTION
-}
-
-package_mips64el-unknown-linux-gnu-gcc-objc()
-{
- pkgdesc="Objective-C front-end for GCC"
- depends=("${_target}-gcc=$pkgver-$pkgrel")
-
- cd gcc-build
- make -j1 DESTDIR=$pkgdir install-target-libobjc
- install -dm755 $pkgdir/usr/lib/gcc/$_target/$pkgver/
- install -m755 gcc/cc1obj{,plus} $pkgdir/usr/lib/gcc/$_target/$pkgver/
-
- # remove libraries included in gcc-libs
- rm -f ${pkgdir}${_sysroot}/lib{,32}/libobjc.so*
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/${_target}-gcc-objc/RUNTIME.LIBRARY.EXCEPTION
-}
-
-package_gcc-ada()
-{
- pkgdesc="Ada front-end for GCC (GNAT)"
- depends=("${_target}-gcc=$pkgver-$pkgrel")
- install=gcc-ada.install
-
- cd gcc-build/gcc
- make -j1 DESTDIR=$pkgdir ada.install-{common,info}
- install -m755 gnat1 $pkgdir/usr/lib/gcc/$_target/$pkgver
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/gcc-ada/RUNTIME.LIBRARY.EXCEPTION
-}
-
-package_gcc-go()
-{
- pkgdesc="Go front-end for GCC"
- depends=("${_target}-gcc=$pkgver-$pkgrel")
- install=gcc-go.install
-
- cd gcc-build
- make -j1 DESTDIR=$pkgdir install-target-libgo
- make -j1 -C gcc DESTDIR=$pkgdir go.install-{common,man,info}
- install -Dm755 gcc/go1 $pkgdir/usr/lib/gcc/$_target/$pkgver/go1
-
- # Install Runtime Library Exception
- install -Dm644 ${_basedir}/COPYING.RUNTIME \
- ${pkgdir}/usr/share/licenses/gcc-go/RUNTIME.LIBRARY.EXCEPTION
-}
-md5sums=('4755b9f6ac0abecbaa2097ed9738406a'
- '450772ce32daed97d7383199f8797f33'
- '4030ee1c08dd1e843c0225b772360e76'
- '67e337993d821d72fccacbed52d48c34'
- '4df25b623799b148a0703eaeec8fdf3f')