summaryrefslogtreecommitdiff
path: root/libre-testing/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/iceweasel/PKGBUILD')
-rw-r--r--libre-testing/iceweasel/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/libre-testing/iceweasel/PKGBUILD b/libre-testing/iceweasel/PKGBUILD
index ac424c241..6a5d6db21 100644
--- a/libre-testing/iceweasel/PKGBUILD
+++ b/libre-testing/iceweasel/PKGBUILD
@@ -136,6 +136,10 @@ END
END
fi # end [[ $CARCH = arm* ]]
+ if [[ $CARCH = i686 ]]; then
+ sed -i '/--enable-linker=gold/d' .mozconfig
+ fi # Because gold linker is alergic to some of the compile options set below to limit memory use.
+
## Rebranding
local brandingdir="$srcdir/$pkgname-$_brandingver"
rm -rf -- browser/branding/$pkgname
@@ -190,6 +194,12 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ if [[ $CARCH = i686 ]]; then
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ echo "Fixing x32 memory limits"
+ fi #Fix Memory issue
+
# LTO needs more open files
ulimit -n 4096