summaryrefslogtreecommitdiff
path: root/libre-testing/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/iceweasel/PKGBUILD')
-rw-r--r--libre-testing/iceweasel/PKGBUILD59
1 files changed, 15 insertions, 44 deletions
diff --git a/libre-testing/iceweasel/PKGBUILD b/libre-testing/iceweasel/PKGBUILD
index 8c76042d9..b9de99364 100644
--- a/libre-testing/iceweasel/PKGBUILD
+++ b/libre-testing/iceweasel/PKGBUILD
@@ -28,9 +28,9 @@
_pkgname=firefox
pkgname=iceweasel
epoch=1
-pkgver=60.0
+pkgver=61.0.1
pkgrel=0.testing1
-_bver=60.0
+_bver=61.0
_brel=1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
arch=(x86_64)
@@ -38,10 +38,10 @@ arch+=(i686 armv7h)
license=(MPL GPL LGPL)
url="https://wiki.parabola.nu/$pkgname"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font libpulse libvpx icu)
+ nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
depends+=('icu>=61' 'icu<62')
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm jack gtk2)
+ autoconf2.13 rust mercurial clang llvm jack gtk2 python)
makedepends+=(mozilla-searchplugins quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -51,45 +51,27 @@ options=(!emptydirs !makeflags !strip)
replaces=("$_pkgname")
conflicts=("$_pkgname")
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
- complete-csd-window-offset-mozilla-1457691.patch.xz
- 0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch.xz
- $pkgname.desktop
- no-crmf.diff)
+ $pkgname.desktop)
source+=(https://repo.parabola.nu/other/iceweasel/${pkgname}_$_bver-$_brel.branding.tar.xz{,.sig}
libre.patch)
-sha256sums=('4bc4fd997e6239f53e16a70b04f197791e5c5d09367e2916bcfe4a427999f842'
- 'a3fb3c3b6fb775c99afdbad507848b77c5e4bbaac2e8ceeb1bfb47699c4b6268'
- '8422030440032535d918844263fbd92d39bff207acb5fff55ed0afee38bcf582'
+sha256sums=('708f4dc39fdf105fe9d3ee6b52412a1c7548fd7d34e14c29f840064de3fe8a28'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
- '02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
- '2d02606d8010ea4fb6a29662d9440d6a4baecae6494ded06cac9174f02428955'
+ 'dabd5a0b8023e8ca13f6ae5fcb9e6c29531fc952bc781b4aa25c8a598187768e'
'SKIP'
- 'b454a871490891187f07720521234b17e4117c35e2abd556dd3be9fb8193806a')
+ 'f2f3484a5339c7208a2a44b63a185ec5a57f837040627d29cc45b4d1d14ef6c2')
validpgpkeys=('BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
prepare() {
- mkdir path
- ln -s /usr/bin/python2 path/python
-
cd firefox-$pkgver
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1283299#c158
- patch -Np1 -i ../complete-csd-window-offset-mozilla-1457691.patch
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1435212
- patch -Np1 -i ../0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
- patch -Np1 -i ../no-crmf.diff
-
cat >.mozconfig <<END
ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-gold
-ac_add_options --enable-pie
-ac_add_options --enable-optimize="-O2"
+ac_add_options --enable-linker=gold
+ac_add_options --enable-hardening
+ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
# Branding
@@ -106,7 +88,6 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -116,7 +97,6 @@ ac_add_options --enable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
-ac_add_options --disable-stylo
ac_add_options --disable-eme
END
@@ -178,7 +158,7 @@ END
# Disable various components at the source level
sed -i 's|[;]1|;0|' toolkit/components/telemetry/TelemetryStartup.manifest || die "failed break telemetry startup"
- sed -i 's|[;]1|;0|' browser/experiments/Experiments.manifest || die "failed to break ExperimentsService"
+ #sed -i 's|[;]1|;0|' browser/experiments/Experiments.manifest || die "failed to break ExperimentsService"
sed -i '/pocket/d' browser/extensions/moz.build || die "failed to wipe pocket"
sed -i '/activity-stream/d' browser/extensions/moz.build || die "failed to wipe activity-stream"
}
@@ -186,15 +166,8 @@ END
build() {
cd firefox-$pkgver
- # _FORTIFY_SOURCE causes configure failures
- CPPFLAGS+=" -O2"
-
- export PATH="$srcdir/path:$PATH"
export MOZ_SOURCE_REPO="$_repo"
- # Do PGO
- #xvfb-run -a -n 95 -s "-extension GLX -screen 0 1280x1024x24" \
- # MOZ_PGO=1 ./mach build
./mach build
./mach buildsymbols
}
@@ -210,6 +183,9 @@ package() {
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+
// Disable default browser checking.
pref("browser.shell.checkDefaultBrowser", false);
@@ -544,11 +520,6 @@ END
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- # Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh