summaryrefslogtreecommitdiff
path: root/libre-testing/tar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre-testing/tar/PKGBUILD')
-rw-r--r--libre-testing/tar/PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/libre-testing/tar/PKGBUILD b/libre-testing/tar/PKGBUILD
new file mode 100644
index 000000000..580cc67d4
--- /dev/null
+++ b/libre-testing/tar/PKGBUILD
@@ -0,0 +1,49 @@
+# Mainainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=tar
+pkgver=1.30
+pkgrel=1
+pkgdesc='Utility used to store, backup, and transport files'
+arch=('x86_64' 'ppc64le')
+url='https://www.gnu.org/software/tar/'
+license=('GPL3')
+groups=('base')
+depends=('glibc' 'acl' 'attr')
+options=('!emptydirs')
+validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732') # Sergey Poznyakoff
+source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+md5sums=('2d01c6cd1387be98f57a0ec4e6e35826'
+ 'SKIP')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --libexecdir=/usr/lib/tar
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make check
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: