summaryrefslogtreecommitdiff
path: root/libre/clementine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/clementine/PKGBUILD')
-rw-r--r--libre/clementine/PKGBUILD56
1 files changed, 29 insertions, 27 deletions
diff --git a/libre/clementine/PKGBUILD b/libre/clementine/PKGBUILD
index dffb5bc70..e720efa71 100644
--- a/libre/clementine/PKGBUILD
+++ b/libre/clementine/PKGBUILD
@@ -1,22 +1,21 @@
-# Maintainer (Arch): Maxime Gauduin <alucryd@archlinux.org>
-# Contributor (Arch): Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor (Arch): BlackEagle <ike.devolder@gmail.com>
-# Contributor (Arch): Dany Martineau <dany.luc.martineau@gmail.com>
-# Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
-# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
+# Maintainer (arch): Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: BlackEagle <ike.devolder@gmail.com>
+# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+# Contributor: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
# Contributor: Kete <kete@ninthfloor.org>
-# rationale for inclusion in libre:
+
+# parabola changes and rationale:
# - replaced nonfree nyancat artwork with moognu
# - removed spotify support
-#
-# additional changes:
-# - build from release tarball instead of VCS
+
pkgname=clementine
-pkgver=1.4.0rc1
-pkgrel=1
+pkgver=1.4.0rc1+495+g10bf5dc17
+pkgrel=2
pkgrel+=.parabola1
pkgdesc='A modern music player and library organizer'
pkgdesc+=', without nonfree artwork and Spotify support'
@@ -24,7 +23,8 @@ url=https://www.clementine-player.org/
license=(GPL)
arch=(x86_64)
arch+=(i686 armv7h)
-depends=(chromaprint crypto++ glew gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5 protobuf qt5-x11extras)
+depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
+ taglib protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
makedepends=(boost cmake qt5-tools sparsehash)
optdepends=(
'gst-plugins-base: "Base" plugin libraries'
@@ -34,18 +34,20 @@ optdepends=(
'gst-libav: Libav plugin'
'gvfs: Various devices support'
)
-source=("https://github.com/clementine-player/Clementine/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
- remove-nonfree-artwork-and-spotify.patch
- moognu.png)
+source=("https://github.com/clementine-player/Clementine/releases/download/${pkgver//+/-}/$pkgname-${pkgver//+/-}.tar.xz")
+source+=(remove-nonfree-artwork-and-spotify.patch
+ moognu.png)
-sha256sums=('96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459'
- '75536b5290ebcd6126d9e8796c3f15a0b0d5339257060ebab511dfe665d64e32'
- 'c6918617769152f3617c61f721819e69d03f671b85760b11cfe45abd53955bc4')
+sha256sums=('b61c7051b6282af3a5717a4d9e755e1b53e08a04339c6eb4b6df77521606cc03')
+sha256sums+=('d9b19730e792e15d026cc4b89019be032c4c4843aace421df418b8111fc5e79f'
+ 'c6918617769152f3617c61f721819e69d03f671b85760b11cfe45abd53955bc4')
prepare() {
+ sed -e 's|CRYPTOPP cryptopp|CRYPTOPP libcryptopp|' -i $pkgname-${pkgver//+/-}/CMakeLists.txt # Fix crypto++ detection
+
mkdir -p build
- cd "$pkgname-$pkgver"
+ cd "$pkgname-${pkgver//+/-}"
# remove nonfree artwork for the Nyan Cat plugin
# https://labs.parabola.nu/issues/329
@@ -71,18 +73,18 @@ prepare() {
# https://labs.parabola.nu/issues/329
install -m644 -v ../moognu.png data
- # create a blank file because it's a dependency for Clementine
+ # create an empty file because it's a dependency for Clementine
touch data/schema/schema-30.sql
}
build() {
- cd build
-
- cmake ../$pkgname-$pkgver \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B build -S $pkgname-${pkgver//+/-} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_PROJECTM=ON \
+ -DUSE_SYSTEM_TAGLIB=ON
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" -C build install
+ DESTDIR="$pkgdir" cmake --install build
}