summaryrefslogtreecommitdiff
path: root/libre/cowsay/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/cowsay/PKGBUILD')
-rw-r--r--libre/cowsay/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/libre/cowsay/PKGBUILD b/libre/cowsay/PKGBUILD
new file mode 100644
index 000000000..77689ca14
--- /dev/null
+++ b/libre/cowsay/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id$
+# Maintainer (Arch): Guillaume ALAUX <guillaume@archlinux.org>
+# Contributor (Arch): Eric Belanger <eric@archlinux.org>
+# Contributor (Arch): Sarah Hay <sarahhay@mb.sympatico.ca>
+# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
+
+pkgname=cowsay
+pkgver=3.03
+pkgrel=9.parabola1
+pkgdesc='Configurable talking cow (and a few other creatures)'
+arch=('any')
+url='http://www.nog.net/~tony/warez/'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+#http://www.nog.net/~tony/warez/${pkgname}-${pkgver}.tar.gz
+source=(http://http.debian.net/debian/pool/main/c/${pkgname}/${pkgname}_${pkgver}+dfsg1.orig.tar.gz
+ cowsay.patch)
+sha256sums=('10bae895d9afb2d720d2211db58f396352b00fe1386c369ca3608cbf6497b839'
+ 'aa88442a31f01ffe5884b3ae974ed1ced23d860859d7f2234cdcd3ac437fc17f')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}+dfsg1
+ patch -p1 -i $srcdir/cowsay.patch
+ sed -i 's|/man/|/share/man/|' install.sh
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}+dfsg1
+ echo "${pkgdir}/usr" | ./install.sh
+ # This one is not a valid '.cow' file
+ rm ${pkgdir}/usr/share/cows/mech-and-cow
+}