summaryrefslogtreecommitdiff
path: root/libre/epiphany/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/epiphany/PKGBUILD')
-rw-r--r--libre/epiphany/PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/libre/epiphany/PKGBUILD b/libre/epiphany/PKGBUILD
index 5c4b4242a..965110803 100644
--- a/libre/epiphany/PKGBUILD
+++ b/libre/epiphany/PKGBUILD
@@ -14,7 +14,7 @@
# - pin to sodeps
pkgname=epiphany
-pkgver=41.3
+pkgver=42.3
pkgrel=1
pkgrel+=.parabola1
pkgdesc="A GNOME web browser based on the WebKit rendering engine"
@@ -23,24 +23,21 @@ url="https://wiki.gnome.org/Apps/Web"
arch=(x86_64)
arch+=(i686 armv7h)
license=(GPL)
-depends=(webkit2gtk-4.1 gcr icu libdazzle libhandy libarchive)
+depends=(webkit2gtk-4.1 gcr icu libdazzle libhandy libarchive libportal-gtk3)
depends=( $( sed 's| icu | |' <<<${depends[@]} ) )
depends+=(libhogweed.so)
makedepends=(docbook-xml startup-notification lsb-release gobject-introspection
yelp-tools git meson)
-makedepends=( ${makedepends[*]/meson/meson<0.61.0} ) # FIXME: FTBS with meson 0.61.x
- # "epiphany/data/meson.build:18:0: ERROR: Function does not take positional arguments."
- # possibly related: https://cgit.freebsd.org/ports/commit/?id=299348602e6d75b6f85b2e7303a0bea5f37541b6
checkdepends=(xorg-server-xvfb aspell hspell hunspell nuspell libvoikko)
groups=(gnome)
-_commit=ce3713dfd4f69275c2c46a6687c24deb8b8aa367 # tags/41.3^0
+_commit=6cdf86702e747867b2f4b338429733f84f554f80 # tags/42.3^0
source=("git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit")
source+=(libre.patch)
sha256sums=('SKIP')
-sha256sums+=('2ef991ade98fbe9a3a6cd80220d3348e69007abff5141bea42bbdf1c72836689')
+sha256sums+=('bf1dd1692ec9f94f8fc669a5ee71dd811d6083465dbb197e3fcc64e2aaf2f709')
# check() requires networking
-_run_check=1
+_run_check=0
pkgver() {
@@ -56,7 +53,7 @@ prepare() {
}
build() {
- arch-meson $pkgname build -D soup2=disabled -D libportal=disabled
+ arch-meson $pkgname build -D soup2=disabled
meson compile -C build
}