summaryrefslogtreecommitdiff
path: root/libre/epiphany/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/epiphany/PKGBUILD')
-rw-r--r--libre/epiphany/PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/libre/epiphany/PKGBUILD b/libre/epiphany/PKGBUILD
index 77dfcb522..78b03a794 100644
--- a/libre/epiphany/PKGBUILD
+++ b/libre/epiphany/PKGBUILD
@@ -15,7 +15,7 @@
pkgname=epiphany
pkgver=42.3
-pkgrel=2
+pkgrel=3
pkgrel+=.parabola1
pkgdesc="A GNOME web browser based on the WebKit rendering engine"
pkgdesc+=", with DuckDuckGo-HTML search"
@@ -24,7 +24,8 @@ arch=(x86_64)
arch+=(i686 armv7h)
license=(GPL)
depends=(webkit2gtk-4.1 gcr icu libdazzle libhandy libarchive)
-# we don't have libportal-gtk3 yet on armv7h and i686
+# we don't have libportal-gtk3 yet on i686
+depends_armv7h+=(libportal-gtk3)
depends_x86_64+=(libportal-gtk3)
depends=( $( sed 's| icu | |' <<<${depends[@]} ) )
depends+=(libhogweed.so)
@@ -55,7 +56,7 @@ prepare() {
}
build() {
- if [ "${CARCH}" = "x86_64" ] ; then
+ if [ "${CARCH}" != "i686" ] ; then
arch-meson $pkgname build -D soup2=disabled
else
arch-meson $pkgname build -D soup2=disabled -D libportal=disabled