summaryrefslogtreecommitdiff
path: root/libre/file-roller/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/file-roller/PKGBUILD')
-rw-r--r--libre/file-roller/PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/libre/file-roller/PKGBUILD b/libre/file-roller/PKGBUILD
index 4c3372e57..4205ab6d8 100644
--- a/libre/file-roller/PKGBUILD
+++ b/libre/file-roller/PKGBUILD
@@ -3,22 +3,21 @@
# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
pkgname=file-roller
-pkgver=3.22.3
+pkgver=3.24.1
pkgrel=1.parabola1
pkgdesc="Create and modify archives, without nonfree unace and unrar recommendation"
url="https://wiki.gnome.org/Apps/FileRoller"
arch=(i686 x86_64 armv7h)
license=(GPL)
depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
-makedepends=(intltool itstool docbook-xsl gnome-common git)
+makedepends=(intltool itstool docbook-xsl gnome-common git libnautilus-extension)
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'lrzip: lrzip archive support')
replaces=("${pkgname}-libre" "${pkgname}-parabola")
conflicts=("${pkgname}-libre" "${pkgname}-parabola")
groups=(gnome-extra)
-options=(!emptydirs)
-_commit=3bf4c97b388b9a4f6095aa8c454831324af51e34 # tags/3.22.3^0
-source=("git://git.gnome.org/file-roller#commit=$_commit")
+_commit=e6ef6fa43a6d5d6e1509f122a206870adc113563 # tags/3.24.1^0
+source=("git+https://git.gnome.org/browse/file-roller#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
@@ -33,12 +32,9 @@ prepare() {
build() {
cd $pkgname
-
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--libexecdir=/usr/lib/$pkgname --disable-static --disable-schemas-compile
-
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
make
}