summaryrefslogtreecommitdiff
path: root/libre/file-roller/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/file-roller/PKGBUILD')
-rw-r--r--libre/file-roller/PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/libre/file-roller/PKGBUILD b/libre/file-roller/PKGBUILD
index 0da92c398..4a0baacf5 100644
--- a/libre/file-roller/PKGBUILD
+++ b/libre/file-roller/PKGBUILD
@@ -3,32 +3,32 @@
# Contributor (Arch): Jan de Groot <jgc@archlinux.org>
pkgname=file-roller
-pkgver=3.20.1
+pkgver=3.20.2
pkgrel=1.parabola1
pkgdesc="Create and modify archives, without nonfree unace and unrar recommendation"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('desktop-file-utils' 'gtk3' 'hicolor-icon-theme' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
-makedepends=('intltool' 'pkg-config' 'libnautilus-extension' 'itstool' 'docbook-xsl')
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch=(i686 x86_64)
+license=(GPL)
+depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
+makedepends=(intltool libnautilus-extension itstool docbook-xsl)
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'lrzip: lrzip archive support')
-groups=('gnome-extra')
replaces=("${pkgname}-libre" "${pkgname}-parabola")
conflicts=("${pkgname}-libre" "${pkgname}-parabola")
-options=('!emptydirs')
+groups=(gnome-extra)
+options=(!emptydirs)
install=file-roller.install
-url="http://www.gnome.org"
source=(https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('c8b3db59ae12d0efde2e8e28d0cb475508ffc33bf08aa5194fbf5f702b6aa333')
+sha256sums=('93188a7ac9285cb85551c327082aeaeb51ac39a9722cb96b0e29d5ec2ae353c6')
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/file-roller \
- --localstatedir=/var --disable-static \
- --disable-schemas-compile
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --libexecdir=/usr/lib/$pkgname --disable-static --disable-schemas-compile
+
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
make
}