summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD97
1 files changed, 52 insertions, 45 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index a7e23629e..fecf3d823 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -41,11 +41,11 @@
pkgname=iceweasel
replaces=('firefox')
epoch=1
-pkgver=68.0.2
+pkgver=69.0
pkgrel=1
pkgrel+=.parabola1
-_brandingver=67.0
-_brandingrel=2
+_brandingver=69.0
+_brandingrel=1
pkgdesc="Libre standalone web browser based on Mozilla Firefox"
arch=(x86_64)
arch+=(i686 armv7h)
@@ -57,7 +57,7 @@ depends+=(sqlite icu)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
python nodejs python2-psutil cbindgen nasm)
-# FIXME: 'mozilla-serarchplugins' package needs re-working
+# FIXME: 'mozilla-serarchplugins' package needs re-working (see note in prepare())
makedepends+=(quilt libxslt imagemagick)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -66,32 +66,32 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !debug)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
+ 0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop
https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
arm.patch
build-arm-libopus.patch
- newtab.patch
libre.patch
searchengines.patch)
-# FIXME: branding tarball needs re-working
-source+=(aboutlogins.svg)
-sha256sums=('9b3e6d8f99819f9eda9ebba403b644a2b96d19450b42cae422bbf4386902a840'
+sha256sums=('413c3febdfeb69eade818824eecbdb11eaeda71de229573810afd641ba741ec5'
'SKIP'
+ 'ab07ab26617ff76fce68e07c66b8aa9b96c2d3e5b5517e51a3c3eac2edd88894'
'e439117380218898cd5c60a8da8947847efbd0fe64cc06b129d6ca20a392cb3d'
- '0151b49e9f5d3bdce64ac0854d84fa5157a65df2d7e16eb683366cbeee021805'
+ 'a6a3771416a51c17e22461abef38b3032c7dc991d223bc374d5bb4d3bc93e9e2'
'SKIP'
'2bb1f6b9b66a00f4f98eb5cdb2f25972018efe042153503cbc8c494780d7225e'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
- '294c88a7aa970f63c44dcb15cd0be12f73679b446804846825a16e4fb4a5d40f'
'783e1b7c2f6f8719cc8a0751aacc823a5029c2326ac0b5ff7c659d831e286387'
'dfed11d97f1d4198a3dc608be159b6b53a11054f376cdb73bb0fe9a487ae9418')
-sha256sums+=('SKIP')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353' # Mozilla Software Releases
'3954A7AB837D0EA9CFA9798925DB7D9B5A8D4B40') # bill-auger
prepare() {
- cd "$srcdir/firefox-$pkgver"
- [[ -d $srcdir/mozbuild ]] && rm -rf $srcdir/mozbuild
+ [[ -d mozbuild ]] && rm -rf mozbuild
+ cd firefox-$pkgver
+
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
## build configuration
cat >.mozconfig <<END
@@ -99,7 +99,6 @@ ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
ac_add_options --enable-release
-ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
@@ -116,6 +115,9 @@ ac_add_options --disable-official-branding
ac_add_options --with-branding=browser/branding/iceweasel
ac_add_options --enable-update-channel=release
ac_add_options --with-distribution-id=nu.parabola
+export MOZ_APP_REMOTINGNAME=${pkgname//-/}
+export MOZ_TELEMETRY_REPORTING=
+export MOZ_REQUIRE_SIGNING=
# System libraries
ac_add_options --enable-system-ffi
@@ -123,9 +125,8 @@ ac_add_options --enable-system-sqlite
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
-# FIXME: does not build against libvpx-1.8.0 - disable --with-system-libvpx
-# libvpx-1.8.1 is in [extra] now - try re-enabling (untested)
-ac_add_options --with-system-libvpx
+# FIXME: does not build against libvpx-1.8.0 or 1.8.1 - disable --with-system-libvpx
+# ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-zlib
@@ -137,6 +138,7 @@ ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-gconf
ac_add_options --disable-updater
+ac_add_options --disable-tests
ac_add_options --disable-eme
END
@@ -152,11 +154,19 @@ END
patch -Np1 -i ../build-arm-libopus.patch
cat >> .mozconfig <<END
+#ac_add_options --enable-linker=gold
ac_add_options --enable-optimize="-O2"
+ac_add_options --disable-rust-simd
ac_add_options --disable-lto
+ac_add_options --disable-webrtc
ac_add_options --disable-elf-hack
ac_add_options --disable-av1
-mk_add_options MOZ_MAKE_FLAGS="$MAKEFLAGS"
+# mk_add_options MOZ_MAKE_FLAGS="$MAKEFLAGS"
+export CC=gcc
+export CXX=g++
+export AR=gcc-ar
+export NM=gcc-nm
+export RANLIB=gcc-ranlib
END
fi
@@ -180,32 +190,26 @@ END
local brandingdestdir=browser/branding/${pkgname}
rm -rf -- ${brandingdestdir}
cp -aT -- ${brandingsrcdir}/branding ${brandingdestdir}
- # FIXME: dont know what aboutlogins.svg is supposed to be or what it is for
- # but it should go into the branding repo
+ # TODO: dont know what aboutlogins.svg is supposed to be or where it is presented
+ # but it seems to be essential
cp ${brandingdestdir}/iceweasel_logo.svg ${brandingdestdir}/content/aboutlogins.svg
+ # custom new tab page
# FIXME: the newtab page (aka "Start Page") has changed significantly
- # some of the branding components (commented out) above may no longer be used
+ # the new upstream start page ('activity-streams') is an add-on now
+ # it must be forked and customized externally, then copied into the browser tree
+ # see: the branding-dev-build/ dir on the '68.0' branch of the branding git repo
+ # that will also be useful for creating a replacement 'mozilla-searchplugins' package
+ # some of the branding components above and commented out below may no longer be used
# the following section aims to restore something similar
- # as the previous parabola-branded "start page"
- # this is untested - once it is working well, all of these comments should be removed
+ # to the previous parabola-branded "start page"
+ # once it is working well, all of these comments should be removed
# and any unused branding components may be deleted from the branding package
- # this is essentially re-branding, so perhaps 'newtab.patch' should eventually
- # be moved into the branding tarball
- # Put "Start Page" branding images in the source code # FIXME: delete
+ # Put "Start Page" branding images in the source code
#install -m644 -t browser/base/content/abouthome -- \
- # "${brandingsrcdir}/branding"/{drm-free,gnu_headshadow,parabola-banner}.png # FIXME: delete
+ # "${brandingsrcdir}/branding"/{drm-free,gnu_headshadow,parabola-banner}.png
#install -m644 -t browser/extensions/onboarding/content/img -- \
- # "${brandingsrcdir}/branding/watermark.svg" # FIXME: delete
- # FIXME: newtab patch below will not work
- # the new tab page needs to be a plugin, created externally
- # see: the branding-dev-build/ dir on the '68.0' branch of the branding git repo
- # that will also be useful for creating a replacement 'mozilla-searchplugins' package
- # custom new tab page
- local newtabdestdir=browser/components/newtab/data/content/assets/
- patch -Np1 -i "${srcdir}/newtab.patch"
- install -m644 "${brandingsrcdir}"/branding/iceweasel_logo.svg ${newtabdestdir}
- install -m644 "${brandingsrcdir}"/branding/parabola-banner.png ${newtabdestdir}
+ # "${brandingsrcdir}/branding/watermark.svg"
# produce icons
for i in 16 22 24 32 48 64 128 192 256 384; do
@@ -250,13 +254,17 @@ END
}
build() {
- cd "$srcdir/firefox-$pkgver"
+ cd firefox-$pkgver
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+
if [[ $CARCH = armv7h ]]; then
- export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
- export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ # FIXME: wip ARM FTBS (memory exhausted)
+# export RUSTFLAGS+=" -Cdebuginfo=0"
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off -Copt-level=0"
+# export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ export LDFLAGS+="-Wl,--no-keep-memory -Wl,--no-keep-files-mapped -Wl,--no-map-whole-files -Wl,--no-mmap-output-file"
fi
if [[ $CARCH = i686 ]]; then
@@ -264,10 +272,10 @@ build() {
export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
fi
- if [[ $CARCH = x86_64 ]]; then
- # LTO needs more open files
- ulimit -n 4096
+ # LTO needs more open files
+ ulimit -n 4096
+ if [[ $CARCH = x86_64 ]]; then
xvfb-run -a -n 97 -s "-screen 0 1600x1200x24" ./mach build
else
./mach build
@@ -280,8 +288,7 @@ package() {
_icu_ver=$(pacman -S --print-format='%v' icu)
depends+=("icu>=${_icu_ver}" "icu<$((${_icu_ver%%.*} + 1))")
- cd "$srcdir/firefox-$pkgver"
-
+ cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +