summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD31
1 files changed, 28 insertions, 3 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 55bcbc971..e85ddc226 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -66,14 +66,16 @@ source=("https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox
$pkgname.desktop
https://repo.parabola.nu/other/iceweasel/${pkgname}_${_brandingver}-${_brandingrel}.branding.tar.xz{,.sig}
libre-searchengines.patch
- libre.patch)
+ libre.patch
+ mozilla-1463035.patch)
sha256sums=('67e517f6d1ea8aa5c8f32404b8756f3205c3550917a91a19b0a0edccc656a3cc'
'SKIP'
'ed350ef2f528b999a621f7080fa80948be6b351e67ce32529fb32bcf47bb21fa'
'4e4d52addfb0de4b4439e959e5c35194e35a6840a21dcf6b20c46604ae7f6482'
'SKIP'
'871222c88dfd240b1805b28c98ca7431bd2b87be1ff4dbb06caa6407b106b803'
- '4a4667d99ab50b1990de6833e9647ddd428d9206e422c7cc3754d4f80aeb8038')
+ '4a4667d99ab50b1990de6833e9647ddd428d9206e422c7cc3754d4f80aeb8038'
+ '8ed5baf2c10665cf49b823e35a4be9c495c8e87066a8c8357a996ea1762b013a')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353' # Mozilla Software Releases
'BFA8008A8265677063B11BF47171986E4B745536') # Andreas Grapentin
@@ -126,11 +128,28 @@ ac_add_options --disable-eme
END
if [[ $CARCH = arm* ]]; then
+ msg "disabling LTO for armv7h build (phase 1/2)"
+ cat >> .mozconfig <<END
+ac_add_options --disable-lto
+export CC=gcc
+export CXX=g++
+export AR=gcc-ar
+export NM=gcc-nm
+export RANLIB=gcc-ranlib
+END
sed -i '/--enable-linker=gold/d' .mozconfig
+ sed -i '/--enable-rust-simd/d' .mozconfig
+ sed -i '/export MOZ_PGO/d' .mozconfig
+
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1463035
+ patch -Np1 -i "$srcdir"/mozilla-1463035.patch
+
cat >> .mozconfig <<END
ac_add_options --enable-optimize="-g -O2 -fno-schedule-insns"
+ac_add_options --disable-webrtc
+ac_add_options --disable-av1
END
- fi # end [[ $CARCH = arm* ]]
+ fi
if [[ $CARCH = i686 ]]; then
msg "disabling LTO for i686 build (phase 1/2)"
@@ -199,6 +218,12 @@ build() {
export MOZ_NOSPAM=1
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ if [[ $CARCH = armv7h ]]; then
+ msg "disabling LTO for armv7h build (phase 2/2)"
+ export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"
+ export LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+ fi
+
if [[ $CARCH = i686 ]]; then
msg "disabling LTO for i686 build (phase 2/2)"
export RUSTFLAGS+=" -Cdebuginfo=0 -Clto=off"