summaryrefslogtreecommitdiff
path: root/libre/iceweasel/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/iceweasel/PKGBUILD')
-rw-r--r--libre/iceweasel/PKGBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/libre/iceweasel/PKGBUILD b/libre/iceweasel/PKGBUILD
index 41939f6f0..0b5c56c4d 100644
--- a/libre/iceweasel/PKGBUILD
+++ b/libre/iceweasel/PKGBUILD
@@ -18,10 +18,10 @@ _pgo=false
# We're getting this from Debian Sid
_debname=firefox
-_brandingver=49.0
+_brandingver=50.0
_brandingrel=1
-_debver=49.0
-_debrel=deb4
+_debver=50.0
+_debrel=deb2
_debrepo=http://ftp.debian.org/debian/pool/main/
_parabolarepo=https://repo.parabola.nu/other/iceweasel
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -30,13 +30,13 @@ _pkgname=firefox
pkgname=iceweasel
epoch=1
pkgver=$_debver.$_debrel
-pkgrel=3
+pkgrel=1
pkgdesc="A libre version of Debian Iceweasel, the standalone web browser based on Mozilla Firefox."
arch=(i686 x86_64 armv7h)
license=(MPL GPL LGPL)
depends=(alsa-lib dbus-glib ffmpeg gtk2 gtk3 hunspell icu=57.1 libevent libvpx=1.6.0 libxt mime-types mozilla-common nss sqlite startup-notification ttf-font)
makedepends=(autoconf2.13 diffutils gconf imagemagick imake inetutils libidl2 libpulse librsvg-stable libxslt mesa mozilla-searchplugins pkg-config python2 quilt unzip yasm zip)
-makedepends_i686=(rust)
+makedepends_i686=(cargo)
makedepends_x86_64=("${makedepends_i686[@]}")
options=(!emptydirs !makeflags debug)
if $_pgo; then
@@ -61,12 +61,14 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
$pkgname.desktop
$pkgname-install-dir.patch
vendor.js
+ rust-i686.patch
+ fix-wifi-scanner.diff
enable-object-directory-paths.patch
mozilla-1253216.patch
mozilla-build-arm.patch)
-sha256sums=('2f463afd3c74eb9477f58525214f06498357ff90f01b45fb2675fc77c57bcffe'
- '8e4051a587e380849226fa0de89a02468c45133a758665dc2a7064a248f138a8'
- 'c0fd88e37187298a7658919cf2e4b6d024425b781d6aff5bdba49dc991f379d3'
+sha256sums=('4be6b691ffc1ac91707c2ced606a0c5fe6620272684f92265f35ef42e19151c5'
+ 'fd3c2b0aaf83404f66cd435463b649c792d6fc65603980148f71cc8a40a4bbc5'
+ 'c9a9f1b712598990ae60810d9e002d340bf0c016e284b11bc4169424b833b641'
'SKIP'
'69d612da53ed7eb04be20d0bfc51eb6e132216a7f7159dde37f4666973ca14d4'
'013af398e97da9e855a143582816bf819e0d9d8d2b0e323d6b832f3df1157fdd'
@@ -75,7 +77,9 @@ sha256sums=('2f463afd3c74eb9477f58525214f06498357ff90f01b45fb2675fc77c57bcffe'
'56eba484179c7f498076f8dc603d8795e99dce8c6ea1da9736318c59d666bff6'
'87034dbb640f70454b27d1695a6f03b6fd1ab81c82eb4d8c771db925ae03d408'
'3aea6676f1e53a09673b6ae219d281fc28054beb6002b09973611c02f827651d'
- 'a1b9c5b988d038d0904c8376b00c705cf55c269d4b14d8cb86c886431f1dafa3'
+ '927a5b01f82af5ca8de024d62031a79faa0dad4746e3acbd968da41a81b15b23'
+ 'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
+ '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8'
'e260e555b261aabab1e48786dd514eeea056e4402af7cfd4dfd1d32858441484'
'fbb6011501a74a8ea6d01c041870fcefb7ef2859c134aedc676e5f6452833f65'
'56eecee8162c138c442773d66483886f1242c8dd2b16eed5711ae5e63d9b0e3a')
@@ -107,7 +111,7 @@ prepare() {
# Enable object directory paths for Iceweasel rebranding
patch -Np1 -i "$srcdir/enable-object-directory-paths.patch"
- # Install to /usr/lib/$pkgname
+ # Install to /usr/lib/iceweasel
patch -Np1 -i "$srcdir/$pkgname-install-dir.patch"
# Patch and remove anything that's left
@@ -124,6 +128,12 @@ prepare() {
# Load our build config, disable SafeSearch
cp "$srcdir/mozconfig" .mozconfig
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
+ patch -Np1 -i ../fix-wifi-scanner.diff
+
+ # Build with the rust targets we actually ship
+ patch -Np1 -i ../rust-i686.patch
+
mkdir "$srcdir/path"
ln -s /usr/bin/python2 "$srcdir/path/python"