summaryrefslogtreecommitdiff
path: root/libre/mate-sensors-applet/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/mate-sensors-applet/PKGBUILD')
-rw-r--r--libre/mate-sensors-applet/PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/libre/mate-sensors-applet/PKGBUILD b/libre/mate-sensors-applet/PKGBUILD
index 7715db075..d843241b9 100644
--- a/libre/mate-sensors-applet/PKGBUILD
+++ b/libre/mate-sensors-applet/PKGBUILD
@@ -1,28 +1,26 @@
# Contributor (Arch): Martin Wimpress <code@flexion.org>
# Maintainer: André Silva <emulatorman@parabola.nu>
-_ver=1.16
-_pkgbase=mate-sensors-applet
-pkgname=(${_pkgbase})
-pkgver=${_ver}.1
+pkgname=mate-sensors-applet
+pkgver=1.18.0
pkgrel=1.parabola1
-pkgdesc="A MATE Panel applet to display readings from hardware sensors, including CPU temperature, fan speeds and voltage readings (GTK2 version), without nonfree libxnvctrl support"
+pkgdesc="A MATE Panel applet to display readings from hardware sensors, including CPU temperature, fan speeds and voltage readings, without nonfree libxnvctrl support"
url="http://mate-desktop.org"
arch=('i686' 'x86_64' 'armv7h')
license=('GPL')
depends=('libatasmart' 'libnotify' 'lm_sensors' 'mate-panel')
makedepends=('docbook-xsl' 'intltool' 'itstool')
groups=('mate-extra')
-conflicts=("${_pkgbase}-gtk3")
-source=("http://pub.mate-desktop.org/releases/${_ver}/${_pkgbase}-${pkgver}.tar.xz")
-sha1sums=('a588b17b8c7ae3d01bb0871a37fa9d726c4637a1')
+conflicts=('mate-sensors-applet-gtk3')
+replaces=('mate-sensors-applet-gtk3')
+source=("http://pub.mate-desktop.org/releases/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz")
+sha1sums=('d83b760cf973ffd0fa74b520605ed50ef3b1858b')
build() {
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd ${pkgname}-${pkgver}
./configure \
--prefix=/usr \
- --libexecdir=/usr/lib/${_pkgbase} \
- --with-gtk=2.0
+ --libexecdir=/usr/lib/${pkgname}
#https://bugzilla.gnome.org/show_bug.cgi?id=656231
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -31,6 +29,6 @@ build() {
}
package() {
- cd "${srcdir}/${_pkgbase}-${pkgver}"
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}