summaryrefslogtreecommitdiff
path: root/libre/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/pacman/PKGBUILD')
-rw-r--r--libre/pacman/PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/libre/pacman/PKGBUILD b/libre/pacman/PKGBUILD
index 09d4e129e..6e7d6c845 100644
--- a/libre/pacman/PKGBUILD
+++ b/libre/pacman/PKGBUILD
@@ -11,6 +11,7 @@
# parabola changes and rationale:
# - adapt config files to support multiple arches
# - allow pacstrap to create cross-arch chroots
+# - disable tests requiring networking
pkgname=pacman
@@ -122,6 +123,14 @@ prepare() {
-e "s|@CARCHFLAGS[@]|$myflags|g" \
-e "s|@LDFLAGS[@]|$myldflags|g"
done
+
+ # neutralize tests requiring networking
+ local net_check_url=https://repo.parabola.nu/check_network_status.txt
+ local sed_rx="s|xfail_tests = {|&\
+ 'tests/sync-failover-404-with-body.py': true,\
+ 'tests/upgrade-download-pkg-and-sig-with-filename.py': true,\
+ 'tests/upgrade-download-pkg-and-sig-without-filename.py': true,|"
+ curl ${net_check_url} &> /dev/null || sed -i "${sed_rx}" test/pacman/meson.build
}
build() {