summaryrefslogtreecommitdiff
path: root/libre/syslinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/syslinux/PKGBUILD')
-rw-r--r--libre/syslinux/PKGBUILD46
1 files changed, 27 insertions, 19 deletions
diff --git a/libre/syslinux/PKGBUILD b/libre/syslinux/PKGBUILD
index 1549ffb22..6377d9864 100644
--- a/libre/syslinux/PKGBUILD
+++ b/libre/syslinux/PKGBUILD
@@ -6,9 +6,9 @@
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
pkgname=syslinux
-pkgver=6.04.pre1.r41.g5e426532
+pkgver=6.04.pre2.r11.gbf6db5b4
#_tag=syslinux-$pkgver
-_commit=5e426532210bb830d2d7426eb8d8c154d9dfcba6
+_commit=bf6db5b4
pkgrel=1
pkgrel+=.par1
pkgdesc='Collection of boot loaders that boot from FAT, ext2/3/4 and btrfs filesystems, from CDs and via PXE (Parabola rebranded)'
@@ -39,23 +39,35 @@ source=(git+https://repo.or.cz/syslinux.git#commit=$_commit
gnu-efi::git://git.code.sf.net/p/gnu-efi/code
syslinux.cfg
syslinux-install_update
- strip_note_section.patch
- single-load-segment.patch
+ 0002-gfxboot-menu-label.patch
+ 0005-gnu-efi-version-compatibility.patch
+ 0017-single-load-segment.patch
+ 0004-gnu-efi-from-arch.patch
+ 0016-strip-gnu-property.patch
+ 0018-prevent-pow-optimization.patch
splash.png)
sha1sums=('SKIP'
'SKIP'
'e40acf4cf9d05ec000c59284f959d1540b35a3be'
'df5160a138ca8c6502d67fe1a64fec78b50e82c2'
- '11d928087764ca286af0327d40230f219348568c'
- '830c88005fb6c9e759f67b91ab33a10b002385de'
+ '69239fda4a3d5a247f0e48c5c683e0124c7d9201'
+ '1e0cd52252622f206d22e84f2a4d358508c902f4'
+ '81d05572b15dc5c55b63489fecdc79a6a332959c'
+ '4c3706e7a5620e450a6abb9238c08d7b39bb6945'
+ 'f4a6768c7e5b8d02428ae550e37a7ca445ad1bb8'
+ 'c94622eaa14ad9512e4f43b13302ba35d1787cbc'
'aab1c7789e0d7290fe87538abad181abac069d40')
sha256sums=('SKIP'
'SKIP'
'67fe3050e60a0d1572293ff095dac2e6cab9da6d0f98fb1fc555850ec046d6ea'
'5f86b5813465c48ba7bd178389aacb5149ff0b5f2467ab1772a4f862c5b15d41'
- '80d783fad7f96077a17634a6b17d8b7750a443221584aa802c096434bdaed603'
- '0ba5667654ecd5b94c1941c7dce7ce945059b1fa70467f6f5a8770a959fcf82b'
+ 'd1fe9084ce2526619f94b8a07b89fb0194e874beef9f202f8b974879d77f2e1a'
+ '8610959df6c01568ff478ca1eb4aac301f3ba1f5bd4739daaec072865e8be2d7'
+ '5b017ba5eae77caa09fa5af6ecfa0df1e7e22776b2b13c8744c6cb7ecd7ad0e9'
+ 'cf3c3da9300d6ea70eab5b8dca724ce03a3651bd63fb0168594dcfeb35eec11c'
+ '7facb5c2abc71c9bfe01bf4db388306ed7b7abf6654009af336262839527f962'
+ '755cd7062fe8495f6f62053ce664451c12ae65dba9fb5c75062a495fbe040fb1'
'a839e3e1242c5279f95f5f913af47be73cf16339c7aa55af378a428c904f1595')
_targets='bios efi32'
@@ -71,11 +83,14 @@ pkgver() {
prepare() {
cd syslinux
- # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414
- patch -p1 < ../strip_note_section.patch
+ patch -p1 < ../0002-gfxboot-menu-label.patch
+ patch -p1 < ../0017-single-load-segment.patch
+ patch -p1 < ../0016-strip-gnu-property.patch
+ patch -p1 < ../0018-prevent-pow-optimization.patch
- # https://bugs.archlinux.org/task/61059
- patch -p1 < ../single-load-segment.patch
+ # TODO: use 'gnu-efi-libs' package instead of embedded sources
+ # patch -p1 < ../0004-gnu-efi-from-arch.patch
+ # patch -p1 < ../0005-gnu-efi-version-compatibility.patch
# do not swallow efi compilation output to make debugging easier
sed 's|> /dev/null 2>&1||' -i efi/check-gnu-efi.sh
@@ -95,13 +110,6 @@ build() {
make PYTHON=python2 $_targets
}
-check() {
- cd syslinux
- # tests fail to compile
- # make unittest
- true
-}
-
package() {
cd syslinux
make $_targets install INSTALLROOT="$pkgdir" SBINDIR=/usr/bin MANDIR=/usr/share/man AUXDIR=/usr/lib/syslinux