summaryrefslogtreecommitdiff
path: root/libre/tp_smapi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/tp_smapi/PKGBUILD')
-rw-r--r--libre/tp_smapi/PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/libre/tp_smapi/PKGBUILD b/libre/tp_smapi/PKGBUILD
index 53b794c5e..9f7a8ae9f 100644
--- a/libre/tp_smapi/PKGBUILD
+++ b/libre/tp_smapi/PKGBUILD
@@ -10,19 +10,18 @@
# Contributor (Hyperbola): Márcio Silva <coadde@hyperbola.info>
# Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
-_basekernel=5.3.7_gnu-1
+_basekernel=5.4.12-1
pkgname=tp_smapi
pkgver=0.43
pkgrel=129
-pkgrel+=.parabola1.basekernel${_basekernel%_*}
+pkgrel+=.parabola1.basekernel${_basekernel%-*}
pkgdesc="Modules for ThinkPad's SMAPI functionality"
pkgdesc+=" (built for the linux-libre kernel package)"
arch=('x86_64')
arch+=('i686')
url='https://github.com/evgeni/tp_smapi'
license=('GPL')
-depends=(linux-libre=${_basekernel%-*})
makedepends=(linux-libre-headers=${_basekernel%-*} git libelf)
_commit=a63729ab30d85430048f65c37f29188ab484cd52 # tags/tp-smapi/0.43
source=("git+https://github.com/evgeni/tp_smapi#commit=$_commit")
@@ -43,6 +42,8 @@ build() {
}
package() {
+ depends=(linux-libre=${_basekernel%-*})
+
local extradir=/usr/lib/modules/$(</usr/src/linux-libre/version)/extramodules
cd $pkgname