summaryrefslogtreecommitdiff
path: root/nonprism/icedove-hardened/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/icedove-hardened/PKGBUILD')
-rw-r--r--nonprism/icedove-hardened/PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/nonprism/icedove-hardened/PKGBUILD b/nonprism/icedove-hardened/PKGBUILD
index 666312043..88b0c504c 100644
--- a/nonprism/icedove-hardened/PKGBUILD
+++ b/nonprism/icedove-hardened/PKGBUILD
@@ -5,7 +5,7 @@
# We're getting this from Debian Sid
_debname=icedove
-_debver=45.4.0
+_debver=45.5.0
_debrel=deb1
_debrepo=http://ftp.debian.org/debian/pool/main/
debfile() { echo $@|sed -r 's@(.).*@\1/&/&@'; }
@@ -25,8 +25,8 @@ options=(!emptydirs !makeflags)
optdepends=('libcanberra: for sound support')
url="https://wiki.parabola.nu/${pkgname%-*}"
replaces=("${pkgname%-*}-libre" "${_pkgname}-hardening" "$_pkgname")
-conflicts=("${pkgname%-*}-libre" "$_pkgname" "${pkgname%-*}")
-provides=("$_pkgname" "${pkgname%-*}")
+conflicts=("${pkgname%-*}-libre" "$_pkgname")
+provides=("$_pkgname" "${pkgname%-*}=$epoch.$pkgver")
install=${pkgname%-*}.install
source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
"$_debrepo/`debfile $_debname`_$_debver-${_debrel#deb}.debian.tar.xz"
@@ -38,15 +38,15 @@ source=("$_debrepo/`debfile $_debname`_$_debver.orig.tar.xz"
fix-missing-files.patch
no-neon.patch
mozilla-1253216.patch)
-sha256sums=('00ff0dcd4bddd053b5285c78cd687876cfab9455c2eb1e670746eb4bedaac38f'
- 'b4d1b193aee7481249ef5e638bf583b69c1785dd530a9ecd098a84f42dfdf09d'
+sha256sums=('953db5edf31101f6cfc546bc2d9c9857134b5a7cfabf2251294a444364b45fa8'
+ '33cc4f2355a7f30f1679dc7ff6c6be9c57c9399f9c5163d719fe1c2a6bb95fc2'
'aaca37bcca176d1b8ebe7c18d3fb0c61e3d21769fbf8e994a189eb3263257d3d'
'0b0d25067c64c6b829c84e5259ffca978e3971f85acc8483f47bdbed5b0b5b6a'
'e1f72c44e31f191271207fc874dcfbf3d504b6b42dc1bb063ba8c7c9ee032130'
'4d1e1ddabc9e975ed39f49e134559a29e01cd49439e358233f1ede43bf5a52bf'
'3a3e84c702ee31450a3e84698441aceb11cf44e64c9fedcaddb8cb50db759417'
'd1ccbaf0973615c57f7893355e5cd3a89efb4e91071d0ec376e429b50cf6ed19'
- '173c929176262c0ad27984d68d61918d51d27bbc538ccbe9e6d19727d1f9de4d'
+ '9a7d1a31274bd2e0b530fbabb2e382a8ce6eba3f06ccada1fecf67654b72d1ed'
'294a2cc7b0477ad285af10ac2a04b767cabec07f03b23da23014bda71caea510'
'59f40d8b2480aa67bf76f4f119826b6828a6a59cc040caf1ab5a6e19eef44c6e'
'1e7ef08acd46aeacc8cd8b2c89012983fb2c8c18648e0f3e9371b0c76caedbde')
@@ -84,6 +84,10 @@ prepare() {
# Fix missing files
patch -Np1 -i "$srcdir/fix-missing-files.patch"
+ # Modify MOZ_APP_NAME for icedove-hardened be installed side by side with icedove
+ sed -i '\|MOZ_APP_NAME| s|icedove|icedove-hardened|
+ ' mail/confvars.sh
+
# Remove url-classifier from package-manifest.in to build and disable Phishing Protection
sed -i '\|Phishing Protection|d
\|UrlClassifier|d
@@ -175,32 +179,32 @@ package() {
cd "$srcdir/$_pkgname-$_debver"
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
- install -Dm644 ../vendor.js "$pkgdir/usr/lib/${pkgname%-*}/defaults/preferences/vendor.js"
+ install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/defaults/preferences/vendor.js"
# Install Icedove menu icon
- install -Dm644 debian/${pkgname%-*}.xpm "$pkgdir/usr/share/pixmaps/${pkgname%-*}.xpm"
+ install -Dm644 debian/${pkgname%-*}.xpm "$pkgdir/usr/share/pixmaps/$pkgname.xpm"
# Install Icedove icons
brandingdir=debian/app-icons
icondir="$pkgdir/usr/share/icons/hicolor"
for i in 16 22 24 32 48 64 128 256; do
install -Dm644 "$brandingdir/${pkgname%-*}$i.png" \
- "$icondir/${i}x${i}/apps/${pkgname%-*}.png"
+ "$icondir/${i}x${i}/apps/$pkgname.png"
done
install -Dm644 "$brandingdir/${pkgname%-*}big.svg" \
- "$icondir/scalable/apps/${pkgname%-*}.svg"
+ "$icondir/scalable/apps/$pkgname.svg"
# Install Icedove desktop
install -d "$pkgdir/usr/share/applications"
install -m644 "$srcdir/${pkgname%-*}.desktop" \
- "$pkgdir/usr/share/applications"
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries
- rm -rf "$pkgdir/usr/lib/${pkgname%-*}/"{dictionaries,hyphenation}
- ln -s /usr/share/hunspell "$pkgdir/usr/lib/${pkgname%-*}/dictionaries"
- ln -s /usr/share/hyphen "$pkgdir/usr/lib/${pkgname%-*}/hyphenation"
+ rm -rf "$pkgdir/usr/lib/$pkgname/"{dictionaries,hyphenation}
+ ln -s /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -s /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
# Replace duplicate binary with symlink
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf ${pkgname%-*} "$pkgdir/usr/lib/${pkgname%-*}/${pkgname%-*}-bin"
+ ln -sf $pkgname "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
}