summaryrefslogtreecommitdiff
path: root/nonprism/icedove/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonprism/icedove/PKGBUILD')
-rw-r--r--nonprism/icedove/PKGBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/nonprism/icedove/PKGBUILD b/nonprism/icedove/PKGBUILD
index 9806966a1..45350a1d5 100644
--- a/nonprism/icedove/PKGBUILD
+++ b/nonprism/icedove/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id$
+# Maintainer (Arch): Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor (Arch): Ionut Biru <ibiru@archlinux.org>
# Contributor (Arch): Alexander Baldeck <alexander@archlinux.org>
@@ -21,44 +21,45 @@ _pkgname=thunderbird
pkgname=icedove
replaces=("$_pkgname")
epoch=1
-pkgver=60.6.1
-pkgrel=3
+pkgver=68.2.2
+pkgrel=2
pkgrel+=.parabola1.nonprism1
-_brandingver=60.5
+_brandingver=68.2
_brandingrel=1
-pkgdesc="Libre standalone mail and news reader based on Mozilla Thunderbird"
-pkgdesc+=", without support for unsafe and dangerous for privacy protocols"
+pkgdesc='Standalone mail and news reader based on Mozilla Thunderbird'
+pkgdesc+=', without support for unsafe and dangerous for privacy protocols'
+url="https://wiki.parabola.nu/$pkgname"
arch=(x86_64)
arch+=(i686 armv7h)
license=(MPL GPL LGPL)
-url="https://wiki.parabola.nu/$pkgname"
-depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib
nss hunspell sqlite ttf-font icu) # libvpx
-makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
- autoconf2.13 rust clang llvm)
+makedepends=(unzip zip diffutils python python2 yasm nasm mesa imake libpulse inetutils xorg-server-xvfb
+ autoconf2.13 rust clang llvm gtk2 cbindgen nodejs)
makedepends+=(quilt mozilla-searchplugins python2-blessings imagemagick)
optdepends=('libcanberra: sound support')
options=(!emptydirs !makeflags)
-source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
- rust-1.33.patch
+source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
$pkgname.desktop
- https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
- mozilla-1238661.patch
- libre-searchengines.patch)
-sha256sums=('17aef9232a76bdc812422883c02b01b4ecb7633c3ee9870da5e4ec0e20ba5f67'
- '97bdb978d59cf5f0f967750e9d8dfbc8fc73367b08437838c44a308fe2ee5442'
+ thunderbird-rust-1.39.patch)
+source+=(
+ https://repo.parabola.nu/other/icedove/${pkgname}_$_brandingver-$_brandingrel.branding.tar.xz{,.sig}
+ libre-searchengines.patch)
+sha256sums=('c17edbcde0e9e7599cda16b69b130039f69113b498ea394057cedfae153f0dd3'
+ 'SKIP'
'af8199a12ebe09189d143458bd1e2d0071aff3410ed121dc2329a448a56632f0'
- '590862b39ba7baf60e47240e33de5839a8e85b6831c839ea57481968c9020241'
+ '08834ef1c2dd685edd40dea20dfa9d4b889f5c387385ac329a162eeff6cf90be'
+ 'b36792a6fcbe68841bc842723222c88ecf1f54f7f75bd634b216b61f3ae422f2'
'SKIP'
- '97b1d3bb2916cd1a297682b3ae4dc679a5afce28610140c73e454b931116028e'
- '9ef9dd18ac1f76ccc3d5d2ace866bb40199fd00a1192da83aef376c585be2ec3')
-validpgpkeys=(BFA8008A8265677063B11BF47171986E4B745536) # Andreas Grapentin
+ '072bba9d9ef4cfcb03b3776a15e52020e05c685add38329bd041f680026f5898')
+validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
+validpgpkeys+=(BFA8008A8265677063B11BF47171986E4B745536) # Andreas Grapentin
prepare() {
cd $_pkgname-$pkgver
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
- patch -Np1 -i ../rust-1.33.patch
+ patch -p1 -i ../thunderbird-rust-1.39.patch # Fix build with rust 1.39 (Gentoo)
+
cat >.mozconfig <<END
ac_add_options --enable-application=comm/mail
@@ -69,7 +70,10 @@ ac_add_options --enable-release
ac_add_options --enable-linker=gold
ac_add_options --enable-hardening
ac_add_options --enable-optimize
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
#ac_add_options --enable-rust-simd
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1423822
+ac_add_options --disable-elf-hack
# Branding
ac_add_options --disable-official-branding
@@ -82,11 +86,9 @@ ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
-# FIXME: does not build against libvpx-1.8.0
# ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -96,6 +98,8 @@ ac_add_options --disable-jack
ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
+ac_add_options --disable-gconf
+# tests require network access.
ac_add_options --disable-tests
END
@@ -104,9 +108,6 @@ END
sed -i '/--enable-hardening/d' .mozconfig
sed -i '/--enable-optimize/d' .mozconfig
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1238661
- patch -Np1 -i "$srcdir"/mozilla-1238661.patch
-
cat >> .mozconfig <<END
ac_add_options --disable-webrtc
ac_add_options --disable-elf-hack
@@ -178,8 +179,8 @@ END
comm/mail/themes/linux/mail/preview.png
# Load our searchplugins
- rm -rv comm/mail/locales/en-US/searchplugins
- cp -av /usr/lib/mozilla/searchplugins comm/mail/locales/en-US/
+ rm -rv comm/suite/locales/en-US/searchplugins
+ cp -av /usr/lib/mozilla/searchplugins comm/suite/locales/en-US/
}
build() {
@@ -233,8 +234,9 @@ pref("social.directories", "");
// Disable the GeoLocation API for content
pref("geo.enabled", false);
+// TODO: this "whats new" page should be in the branding package or abslibre
// Pointing the "Help -> What's new" menu entry to mozilla.debian.net
-pref("mailnews.start_page.override_url", "http://wiki.debian.org/Icedove/WhatsNew45");
+//pref("mailnews.start_page.override_url", "http://wiki.debian.org/Icedove/WhatsNew45");
END
_distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
@@ -261,7 +263,6 @@ END
"$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"