summaryrefslogtreecommitdiff
path: root/nonsystemd/polkit/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/polkit/PKGBUILD')
-rw-r--r--nonsystemd/polkit/PKGBUILD73
1 files changed, 37 insertions, 36 deletions
diff --git a/nonsystemd/polkit/PKGBUILD b/nonsystemd/polkit/PKGBUILD
index 133fcb762..d7d01e09b 100644
--- a/nonsystemd/polkit/PKGBUILD
+++ b/nonsystemd/polkit/PKGBUILD
@@ -1,64 +1,62 @@
-# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Jan de Groot <jgc@archlinux.org>
+# Maintainer: Nathan Owens <ndowens@artixlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=polkit
-pkgver=0.118
+pkgver=121
pkgrel=1
pkgrel+=.nonsystemd1
pkgdesc="Application development toolkit for controlling system-wide privileges"
-arch=(x86_64 i686 armv7h)
+url="https://gitlab.freedesktop.org/polkit/polkit"
+arch=(x86_64)
+arch+=(i686 armv7h)
license=(LGPL)
-url="https://www.freedesktop.org/wiki/Software/polkit/"
-depends=(glib2 pam expat elogind js78)
-makedepends=(intltool gtk-doc gobject-introspection git autoconf-archive)
+depends=(glib2 pam expat elogind js78 duktape)
+makedepends=(meson gtk-doc gobject-introspection git)
+checkdepends=(python-dbusmock)
+provides=(libpolkit-{agent,gobject}-1.so)
backup=(etc/pam.d/polkit-1)
-provides=(polkit-elogind)
-replaces=(polkit-elogind polkit-consolekit)
-_commit=ff4c2144f0fb1325275887d9e254117fcd8a1b52 # git tag 0.118
+options=(debug)
+_commit=827b0ddac5b1ef00a47fca4526fcf057bee5f1db # tags/121
source=("git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit"
'99-parabola.rules'
- 'elogind-configure-fix.patch')
-sha256sums=('SKIP'
- 'd28d6ecaf7682860e2b3768bb266bd94313546b7cd0ef3c2eace7b1576c47adb'
- 'd90b2a95aa3e9e1ebf9369c038c144e04900e095c5405bc4ba4901c31bf3f59b')
+ meson-0.61.diff)
+b2sums=('SKIP'
+ 'd320d928b5480b5b8143717e6f88101912709020efc9583fbb233a2cc11aff51d36226b94cf69104db06f330e04d4dcfd6e4c7b027df75a3c72c43adec625fb2'
+ '29cef1cf9265ec0b70bf5a46655ee51b9855ce64e47636809b9704ca80edaf5777060d7469eea15a4126791d9290d44901726b6496acf83e41f46a96fe137ead')
pkgver() {
- cd $pkgname
- git describe --tags | sed 's/-/+/g'
+ cd polkit
+ git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
- cd $pkgname
- patch -Np 1 -i ${srcdir}/elogind-configure-fix.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd polkit
}
build() {
- cd $pkgname
+ local meson_options=(
+ -D examples=true
+ -D gtk_doc=true
+ -D man=true
+ -D os_type=redhat
+ -D session_tracking=libelogind
+ -D tests=true
+ -D systemdsystemunitdir=foo
+ )
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --libexecdir=/usr/lib \
- --enable-libsystemd-login=no --disable-static \
- --enable-libelogind=yes --with-systemdsystemunitdir=no \
- --enable-gtk-doc --with-os-type=redhat
-
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ arch-meson polkit build "${meson_options[@]}"
+ meson compile -C build
}
check() {
- cd $pkgname
- make -k check || :
+ meson test -C build --print-errorlogs -t 3
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install \
- dbusconfdir=/usr/share/dbus-1/system.d \
- rulesdir=/usr/share/polkit-1/rules.d
+ meson install -C build --destdir "$pkgdir"
install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
+ mv "$pkgdir"/{etc,usr/share}/polkit-1/rules.d/50-default.rules
install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
u polkitd 102 "PolicyKit daemon"
@@ -66,6 +64,9 @@ m polkitd proc
END
install -m0644 "${srcdir}"/99-parabola.rules "${pkgdir}"/etc/polkit-1/rules.d
+
+ # workaround the unit enforcement, atm can't be disabled, needs patching
+ rm -rf "${pkgdir}"/usr/foo
}
-# vim: ts=2 sw=2 et:
+# vim:set sw=2 et: