summaryrefslogtreecommitdiff
path: root/nonsystemd/pulseaudio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'nonsystemd/pulseaudio/PKGBUILD')
-rw-r--r--nonsystemd/pulseaudio/PKGBUILD41
1 files changed, 23 insertions, 18 deletions
diff --git a/nonsystemd/pulseaudio/PKGBUILD b/nonsystemd/pulseaudio/PKGBUILD
index 2a96d303d..1d9238560 100644
--- a/nonsystemd/pulseaudio/PKGBUILD
+++ b/nonsystemd/pulseaudio/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: David P. <megver83@parabola.nu>
-# Maintainer (Arch): Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=pulseaudio
pkgname=(pulseaudio libpulse pulseaudio-{zeroconf,lirc,jack,bluetooth,equalizer,rtp})
pkgdesc="A featureful, general-purpose sound server"
-pkgver=14.2
-pkgrel=2
+pkgver=15.0
+pkgrel=1
pkgrel+=.nonsystemd1
arch=(x86_64)
arch+=(i686 armv7h)
@@ -14,12 +14,10 @@ license=(GPL)
makedepends=(libasyncns libcap attr libxtst libsm libsndfile rtkit libsoxr
speexdsp tdb elogind dbus avahi bluez bluez-libs jack2 sbc
lirc openssl fftw orc gtk3 webrtc-audio-processing check git meson
- xmltoman)
-_commit=6a487c5244563f49a025088de3510c80824fc99e # tags/v14.2^0
-source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit"
- "meson-elogind-support.patch")
-sha256sums=('SKIP'
- 'fea0e09a9f026bc3c9160b53018b8e1dd1f3493c60f68405a758de7d3cb592cf')
+ xmltoman valgrind doxygen)
+_commit=6329a2498eb038f8a9537888280a62b00a93f68e # tags/v15.0^0
+source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
cd pulseaudio
@@ -30,18 +28,22 @@ prepare() {
cd pulseaudio
# Freeze version before patching
- patch -Np 1 -i ../meson-elogind-support.patch
./git-version-gen doesnt-exist >.tarball-version
}
build() {
- arch-meson pulseaudio build \
- -D pulsedsp-location='/usr/\$LIB/pulseaudio' \
- -D stream-restore-clear-old-devices=true \
- -D udevrulesdir=/usr/lib/udev/rules.d \
- -D systemd=disabled \
+ local meson_options=(
+ -D stream-restore-clear-old-devices=true
+ -D pulsedsp-location='/usr/\$LIB/pulseaudio'
+ -D udevrulesdir=/usr/lib/udev/rules.d
+ -D bluez5-gstreamer=disabled
+ -D tcpwrap=disabled
+ -D systemd=disabled
-D elogind=enabled
- meson compile -C build
+ )
+
+ arch-meson pulseaudio build "${meson_options[@]}"
+ meson compile -C build
}
check() {
@@ -78,7 +80,7 @@ package_pulseaudio() {
done
pulsever=${pulsever%%-*}
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
cd "$pkgdir"
@@ -106,7 +108,10 @@ package_pulseaudio() {
_pick libpulse usr/include
_pick libpulse usr/share/man/man1/pa{cat,ctl,dsp,mon,play,rec,record}.1
_pick libpulse usr/share/man/man5/pulse-client.conf.5
+ _pick libpulse usr/share/bash-completion/completions/pa{cat,ctl,dsp,play,rec,record}
+ _pick libpulse usr/share/bash-completion/completions/pulseaudio
_pick libpulse usr/share/vala
+ _pick libpulse usr/share/zsh
local moddir=usr/lib/pulse-$pulsever/modules
@@ -133,7 +138,7 @@ package_pulseaudio() {
package_libpulse() {
pkgdesc="$pkgdesc (client library)"
- depends=(dbus libasyncns libcap libxcb libsm libsndfile elogind)
+ depends=(dbus libasyncns libcap libxcb libsm libsndfile libelogind)
optdepends=('glib2: mainloop integration')
provides=(libpulse{,-simple,-mainloop-glib}.so)
license=(LGPL)