summaryrefslogtreecommitdiff
path: root/pcr/gajim-plugin-omemo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/gajim-plugin-omemo/PKGBUILD')
-rw-r--r--pcr/gajim-plugin-omemo/PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/pcr/gajim-plugin-omemo/PKGBUILD b/pcr/gajim-plugin-omemo/PKGBUILD
index a25501859..aff3a3509 100644
--- a/pcr/gajim-plugin-omemo/PKGBUILD
+++ b/pcr/gajim-plugin-omemo/PKGBUILD
@@ -3,34 +3,33 @@
# Maintainer: David P. <megver83@parabola.nu>
# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# Contributor: Wael Karram <wael@waelk.tech>
# parabola changes and rationale:
# no changes.
pkgname=gajim-plugin-omemo
_pkgname=omemo
-pkgver=2.7.13
+pkgver=2.8.15
pkgrel=1
-_pythonversion=3.9
+_pythonversion=3.10
pkgdesc='Gajim plugin for OMEMO Multi-End Message and Object Encryption.'
arch=(any)
url='https://dev.gajim.org/gajim/gajim-plugins/wikis/OmemoGajimPlugin'
license=('GPL')
-depends=('gajim>=1.2.91' 'gajim<=1.3.90' 'python-qrcode' 'python-setuptools' 'python-cryptography' 'python-axolotl')
+depends=('gajim>=1.4' 'gajim<=1.4.90' 'python-qrcode' 'python-setuptools' 'python-cryptography' 'python-axolotl')
provides=('gajim-plugin-omemo')
conflicts=('gajim-plugin-omemo-git')
-source=("https://ftp.gajim.org/plugins_releases/${_pkgname}_${pkgver}.zip")
-sha512sums=('33f7d1132ed9e218e17c8288ad2586b1a9c6d547db93b5b9bb97abcb8df2541bba35d9cc3fcef74d13b35353636cb4ef652805d69eda878d361b029e62fd9ee2')
+source=("https://ftp.gajim.org/plugins/master/${_pkgname}/${_pkgname}_${pkgver}.zip")
+sha512sums=('5c3322239a149512f96b35359f0f423070f2e16f660885f62485306aaf6baeade564c8e5ab2fcfb63c1554dca8624c5d6fda5c0435c83aaafb484c98092fce48')
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}"
# Remove unnecessary files
- rm -r CHANGELOG COPYING
+ rm -f CHANGELOG COPYING
# Install the plugin
install -d "${pkgdir}/usr/lib/python${_pythonversion}/site-packages/gajim/data/plugins/${_pkgname}"
cp -r * "${pkgdir}/usr/lib/python${_pythonversion}/site-packages/gajim/data/plugins/${_pkgname}/"
}
-
-# vim:set ts=2 sw=2 et: