summaryrefslogtreecommitdiff
path: root/pcr/owncloud-client/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/owncloud-client/PKGBUILD')
-rw-r--r--pcr/owncloud-client/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/pcr/owncloud-client/PKGBUILD b/pcr/owncloud-client/PKGBUILD
new file mode 100644
index 000000000..7e8dfa59a
--- /dev/null
+++ b/pcr/owncloud-client/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Kuba Serafinowski <zizzfizzix(at)gmail(dot)com>
+# https://github.com/zizzfizzix/pkgbuilds
+
+##############################################################
+#### The section below can be adjusted to suit your needs ####
+##############################################################
+
+# What type of build do you want?
+# See http://techbase.kde.org/Development/CMake/Addons_for_KDE#Buildtypes to check what is supported.
+# Default is RelWithDebInfo to help with debugging.
+
+_buildtype="RelWithDebInfo"
+
+##############################################################
+
+_name=mirall
+pkgname=owncloud-client
+pkgver=1.0.5
+pkgrel=2
+pkgdesc="ownCloud client based on mirall"
+arch=('i686' 'x86_64')
+url="http://owncloud.org/"
+license=('GPL2')
+depends=('qt' 'csync-owncloud')
+makedepends=('cmake')
+provides=('mirall' 'owncloud-client')
+conflicts=('mirall-git')
+options=(!strip)
+install=owncloud-client.install
+backup=('etc/exclude.lst')
+source=("http://download.owncloud.com/download/${_name}-${pkgver}.tar.bz2"
+ "${pkgname}.desktop")
+md5sums=('b7a96411f092bb16f88e3868a558032f'
+ 'e223d162626c2ff54efebaa90a182d81')
+
+# Clean options array to strip pkg if release buildtype is chosen
+if [[ ${_buildtype} == "Release" ]] || [[ ${_buildtype} == "release" ]]; then
+ options=()
+fi
+
+build() {
+ if [[ -e ${srcdir}/${_name}-${pkgver}-build ]]; then rm -rf ${srcdir}/${_name}-${pkgver}-build; fi
+ mkdir ${srcdir}/${_name}-${pkgver}-build
+ cd ${srcdir}/${_name}-${pkgver}-build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DCMAKE_BUILD_TYPE=${_buildtype} ../${_name}-${pkgver}
+ make
+}
+
+package() {
+ cd ${srcdir}/${_name}-${pkgver}-build
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}