summaryrefslogtreecommitdiff
path: root/pcr/pulledpork/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/pulledpork/PKGBUILD')
-rw-r--r--pcr/pulledpork/PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/pcr/pulledpork/PKGBUILD b/pcr/pulledpork/PKGBUILD
index aeeac0a04..c8c73f25c 100644
--- a/pcr/pulledpork/PKGBUILD
+++ b/pcr/pulledpork/PKGBUILD
@@ -1,19 +1,26 @@
-# Contributor (Arch): Isaac C. Aronson <i@pingas.org>
+# Maintainer (AUR): Amish <contact at via dot aur>
+# Contributor (AUR): Isaac C. Aronson <i@pingas.org>
# Maintainer : Parabola GNU / Linux-libre Aurelien Desbrieres <aurelien@cwb.io>
pkgname=pulledpork
-pkgver=0.6.1
-pkgrel=3
+pkgver=0.7.3
+pkgrel=1
pkgdesc="Tool to automatically update rules for snort"
arch=('any')
-url="http://code.google.com/p/pulledpork"
+url="https://github.com/${_user}/${pkgname}"
license=('GPL')
-depends=('perl' 'perl-lwp-protocol-https' 'perl-crypt-ssleay' 'perl-archive-tar' 'perl-switch')
+depends=('cron' 'perl' 'perl-lwp-protocol-https' 'perl-crypt-ssleay' 'perl-archive-tar' 'perl-switch' 'perl-bytes-random-secure')
optdepends=('snort')
-source=(http://pulledpork.googlecode.com/files/pulledpork-0.6.1.tar.gz)
+backup=('etc/pulledpork/pulledpork.conf'
+ 'etc/pulledpork/disablesid.conf'
+ 'etc/pulledpork/dropsid.conf'
+ 'etc/pulledpork/enablesid.conf'
+ 'etc/pulledpork/modifysid.conf')
+source=("pulledpork-${pkgver}.tar.gz::https://github.com/shirkdog/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('48c66dc9abb7545186d4fba497263c1d1b247c0ea7f0953db4d515e7898461a2')
package() {
cd $srcdir/$pkgname-$pkgver
install -Dm644 etc/pulledpork.conf $pkgdir/etc/pulledpork.conf
- install -Dm755 pulledpork.pl $pkgdir/usr/sbin/pulledpork.pl
+ install -Dm755 pulledpork.pl $pkgdir/usr/bin/pulledpork.pl
}