summaryrefslogtreecommitdiff
path: root/pcr/setools/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/setools/PKGBUILD')
-rw-r--r--pcr/setools/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/pcr/setools/PKGBUILD b/pcr/setools/PKGBUILD
new file mode 100644
index 000000000..78531fa3e
--- /dev/null
+++ b/pcr/setools/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer (AUR): Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
+# Contributor (AUR): Timothée Ravier <tim@siosm.fr>
+# Contributor (AUR): Nicky726 <Nicky726 [at] gmail [dot] com>
+# Contributor (AUR): Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+# parabola changes and rationale:
+# - Added armv7h
+
+# /!\ Important note when upgrading from setools 3 /!\
+# When upgrading with policycoreutils 2.5-3, pacman fails with:
+# failed to prepare transaction (could not satisfy dependencies)
+# :: policycoreutils: installing setools (4.0.1-1) breaks dependency 'setools3-libs'
+# In order to upgrade setools, you can either:
+# - build setools 4.0.1-1 and setools3-libs 3.3.8-1 and install both packages
+# at the same time (with a single "pacman -U" command)
+# - temporarily uninstall policycoreutils while upgrading and install it
+# again afterwards, or
+# - replace setools 3.3.8 with setools3-libs and install setools then.
+
+pkgname=setools
+pkgver=4.4.0
+pkgrel=1
+pkgdesc="Policy analysis tools for SELinux"
+groups=('selinux')
+arch=('i686' 'x86_64')
+arch+=('armv7h')
+url="https://github.com/SELinuxProject/setools/wiki"
+license=('GPL' 'LGPL')
+depends=('libsepol>=3.2' 'libselinux>=3.2' 'python' 'python-networkx>=2.0' 'python-setuptools')
+optdepends=('python-pyqt5: needed for graphical tools'
+ 'qt5-tools: display apol help with Qt Assistant')
+makedepends=('cython' 'python-tox')
+checkdepends=('checkpolicy')
+conflicts=("selinux-${pkgname}")
+provides=("selinux-${pkgname}=${pkgver}-${pkgrel}")
+source=("https://github.com/SELinuxProject/setools/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('f3786677e40b7f16a226f48f233dcf835e700739614a7dbed2ff61cc9607814e')
+
+build() {
+ cd "${pkgname}"
+ python setup.py build_ext
+ python setup.py build
+}
+
+check() {
+ cd "${pkgname}"
+ python setup.py test
+}
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}