summaryrefslogtreecommitdiff
path: root/pcr/simtrace/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/simtrace/PKGBUILD')
-rw-r--r--pcr/simtrace/PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/pcr/simtrace/PKGBUILD b/pcr/simtrace/PKGBUILD
index c6ff1c773..d51db16dc 100644
--- a/pcr/simtrace/PKGBUILD
+++ b/pcr/simtrace/PKGBUILD
@@ -1,29 +1,28 @@
-# Contributor: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-pkgname=simtrace-git
-_pkgname=simtrace
-pkgver=0.1.r89.g6fde8e1
-_commit=6fde8e1c26f12069e67103ba5f69a068d78de063
-pkgrel=2
-pkgdesc="Traces the communication between phones and SIM cards with first generation simtrace hardware."
+# Copyright (C) 2020 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+pkgname=simtrace2
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Traces the communication between phones and SIM cards with second generation simtrace hardware."
arch=('armv7h' 'i686' 'x86_64')
-url="http://bb.osmocom.org/trac/wiki/SIMtrace"
+url="https://osmocom.org/projects/simtrace2"
license=('GPL2') # GPLv2-only according to the source files headers
-depends=('libosmocore' 'libusb' 'talloc')
+depends=('libosmocore' 'libusb' 'lksctp-tools' 'talloc')
makedepends=('make' 'gcc' 'git' 'pkg-config')
-source=("git://git.osmocom.org/simtrace.git#commit=$_commit")
+source=("git://git.osmocom.org/simtrace2#tag=$pkgver")
sha512sums=('SKIP')
-pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
build() {
- cd "$srcdir/$_pkgname/host"
+ cd "$srcdir/$pkgname/host"
+ autoreconf -fi
+ ./configure
make
}
package() {
- cd "$srcdir/$_pkgname/host"
+ cd "$srcdir/$pkgname/host"
make DESTDIR=$pkgdir install
}