summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-05-12 06:39:15 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-05-12 07:32:49 -0400
commit4125acf21b4a7c5ed6cb1681a32745b3ebe58cb1 (patch)
tree87cbaf6a660b4023d0285671074322af2e028fbe /CMakeLists.txt
parent218488e7dbfc44168bd8bc835f866ca7bbff3180 (diff)
parent255f1e85a8b272ff39e6466b2d43d6fe5efea253 (diff)
merged upstream v3.2.8v3.2.8-parabola1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 17 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2fee2a13..74be0a37f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,9 @@
#
# SKIP_MODULES : a space or semicolon-separated list of directory names
# under src/modules that should not be built.
+# USE_<foo> : fills in SKIP_MODULES for modules called <foo>-<something>
+# BUILD_<foo> : choose additional things to build
+# DEBUG_<foo> : special developer flags for debugging
#
# Example usage:
#
@@ -32,10 +35,12 @@
# One special target is "show-version", which can be built
# to obtain the version number from here.
-project( calamares C CXX )
-
-cmake_minimum_required( VERSION 3.2 )
+cmake_minimum_required( VERSION 3.2 FATAL_ERROR )
+project( CALAMARES
+ VERSION 3.2.8
+ LANGUAGES C CXX )
+set( CALAMARES_VERSION_RC 0 ) # Set to 0 during release cycle, 1 during development
### OPTIONS
#
@@ -62,7 +67,8 @@ option( WITH_KF5Crash "Enable crash reporting with KCrash." ON )
# all the implementations are enabled (this just means they are
# **available** to `settings.conf`, not that they are used).
#
-# Currently, no USE_<foo> variables exist.
+# Currently, only USE_services is in use (to pick only one of the two
+# modules, systemd or openrc).
set( USE_services "" CACHE STRING "Select the services module to use" )
### Calamares application info
@@ -73,12 +79,6 @@ set( CALAMARES_APPLICATION_NAME "Calamares" )
set( CALAMARES_DESCRIPTION_SUMMARY
"The distribution-independent installer framework" )
-set( CALAMARES_VERSION_MAJOR 3 )
-set( CALAMARES_VERSION_MINOR 2 )
-set( CALAMARES_VERSION_PATCH 4 )
-set( CALAMARES_VERSION_RC 0 )
-
-
### Transifex (languages) info
#
# complete = 100% translated,
@@ -116,7 +116,7 @@ set( _tx_bad be eo fa fr_CH gu kk kn lo mk ne_NP ur uz )
### Required versions
#
# See DEPENDENCIES section below.
-set( QT_VERSION 5.10.0 )
+set( QT_VERSION 5.9.0 )
set( YAMLCPP_VERSION 0.5.1 )
set( ECM_VERSION 5.18 )
set( PYTHONLIBS_VERSION 3.3 )
@@ -189,6 +189,7 @@ if( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
-Wno-exit-time-destructors
-Wno-missing-prototypes
-Wno-documentation-unknown-command
+ -Wno-unknown-warning-option
)
string( APPEND CMAKE_CXX_FLAGS " ${CLANG_WARNINGS}" )
endforeach()
@@ -208,6 +209,8 @@ if( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
set( CMAKE_TOOLCHAIN_PREFIX "llvm-" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
+
+ set( CALAMARES_AUTOMOC_OPTIONS "-butils/moc-warnings.h" )
else()
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,--no-undefined" )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,--fatal-warnings -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type" )
@@ -240,7 +243,7 @@ include( CMakeColors )
### DEPENDENCIES
#
-find_package( Qt5 ${QT_VERSION} CONFIG REQUIRED Core Gui Widgets LinguistTools Svg Quick QuickWidgets )
+find_package( Qt5 ${QT_VERSION} CONFIG REQUIRED Concurrent Core Gui Widgets LinguistTools Svg Quick QuickWidgets )
find_package( YAMLCPP ${YAMLCPP_VERSION} REQUIRED )
if( INSTALL_POLKIT )
find_package( PolkitQt5-1 REQUIRED )
@@ -267,6 +270,7 @@ if( ECM_FOUND )
find_package( Qt5 COMPONENTS Test REQUIRED )
include( ECMAddTests )
endif()
+ include(KDEInstallDirs)
endif()
find_package( KF5 COMPONENTS CoreAddons Crash )
@@ -509,6 +513,7 @@ install(
"CMakeModules/CalamaresAddLibrary.cmake"
"CMakeModules/CalamaresAddBrandingSubdirectory.cmake"
"CMakeModules/CalamaresAddTranslations.cmake"
+ "CMakeModules/CalamaresAutomoc.cmake"
"CMakeModules/CMakeColors.cmake"
DESTINATION
"${CMAKE_INSTALL_CMAKEDIR}"