summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdriaan de Groot <groot@kde.org>2019-04-30 13:38:46 +0200
committerAdriaan de Groot <groot@kde.org>2019-04-30 13:38:46 +0200
commita01262a535f34a328f85c590fce7eb329b12702e (patch)
treed685c9f41bc6c97ac306c9b58ce5c3b279ac9430 /CMakeLists.txt
parent26208295156abf5ee6cce7e2bc0130a24de438e2 (diff)
CMake: massage dependency-finding
- If KPMCore is not found, don't require the KF5 components that it would depend on. - If ECM is found, use KDEInstallDirs always, not just when the partitioning module is used.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac4f7d811..8fe0c0522 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -269,6 +269,7 @@ if( ECM_FOUND )
find_package( Qt5 COMPONENTS Test REQUIRED )
include( ECMAddTests )
endif()
+ include(KDEInstallDirs)
endif()
find_package( KF5 COMPONENTS CoreAddons Crash )