summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2019-06-29 14:31:58 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2019-06-29 14:31:58 -0400
commit1fd9b01961d3a5556b16fe6333d18fa75828cb40 (patch)
tree2691fc620a19d933b878493f630771b9d6286996 /CMakeLists.txt
parentb4357f9d4935e19aab3b4697f5cef6992c674860 (diff)
parent40d1856bb1b910720fd36977abcef5207f31e40f (diff)
merge upstream v3.2.9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 12 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74be0a37f..b069ed71d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@
cmake_minimum_required( VERSION 3.2 FATAL_ERROR )
project( CALAMARES
- VERSION 3.2.8
+ VERSION 3.2.9
LANGUAGES C CXX )
set( CALAMARES_VERSION_RC 0 ) # Set to 0 during release cycle, 1 during development
@@ -104,12 +104,12 @@ set( CALAMARES_DESCRIPTION_SUMMARY
# checks for new languages and misspelled ones are done (that is,
# copy these four lines to four backup lines, add "p", and then update
# the original four lines with the current translations).
-set( _tx_complete ast ca cs_CZ da de fr hr ja lt pl pt_BR pt_PT
- tr_TR zh_TW )
-set( _tx_good bg en_GB es es_MX et gl he hi hu id it_IT ro ru sk sq
- zh_CN )
-set( _tx_ok ar el es_PR eu fi_FI is ko mr nb nl sl sr
- sr@latin sv th uk )
+set( _tx_complete ca cs_CZ da de fr he hr hu ko lt pt_BR sq tr_TR
+ zh_TW )
+set( _tx_good ast en_GB es es_MX et gl id it_IT ja nl pl pt_PT ro
+ ru sk zh_CN )
+set( _tx_ok ar bg el es_PR eu fi_FI hi is mr nb sl sr sr@latin sv
+ th uk )
set( _tx_bad be eo fa fr_CH gu kk kn lo mk ne_NP ur uz )
@@ -193,6 +193,7 @@ if( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
)
string( APPEND CMAKE_CXX_FLAGS " ${CLANG_WARNINGS}" )
endforeach()
+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DNOTREACHED='//'" )
# Third-party code where we don't care so much about compiler warnings
# (because it's uncomfortable to patch) get different flags; use
@@ -203,7 +204,7 @@ if( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
set( CMAKE_CXX_FLAGS_DEBUG "-g ${CMAKE_CXX_FLAGS_DEBUG}" )
set( CMAKE_CXX_FLAGS_MINSIZEREL "-Os -DNDEBUG" )
- set( CMAKE_CXX_FLAGS_RELEASE "-O4 -DNDEBUG" )
+ set( CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG" )
set( CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g" )
set( CMAKE_TOOLCHAIN_PREFIX "llvm-" )
@@ -211,12 +212,15 @@ if( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
set( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined" )
set( CALAMARES_AUTOMOC_OPTIONS "-butils/moc-warnings.h" )
+ set( CALAMARES_AUTOUIC_OPTIONS --include utils/moc-warnings.h )
else()
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,--no-undefined" )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wl,--fatal-warnings -Wnon-virtual-dtor -Woverloaded-virtual -Werror=return-type" )
set( SUPPRESS_3RDPARTY_WARNINGS "" )
set( SUPPRESS_BOOST_WARNINGS "" )
+
+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DNOTREACHED='__builtin_unreachable();'" )
endif()
# Use mark_thirdparty_code() to reduce warnings from the compiler